Problem with the nodes !

hi !
Here is my Blend. http://www.pasteall.org/blend/37389
Why is my object is black and returns to normal when I delete a lamp?
Or when I remove the texture “mat roche bord eau” in the node panel?
In my game I need 20 lamps for car headlights.

I have not looked at the blend but…

The problem is likely to be graphics ram. Every texture, light, material etc. has to be stored on the graphics card. What happens when it’s full? Well, it stops working properly. The solution is to reduce the size of textures, the complexity of materials, or the number of lights.

This is not a graphics card problem. On my laptop (gtx 670m) and on my desktop pc (gtx 970), it’s been exactly the same, you have deleted a single light

I took a look at your file and @sdfgeoff is right, you have way too many lamps in the scene, you can try to turn off shadow for the majority of the spot lamps or better yet delete most of them