Problem with the rendering of an animation: my PC or the Blender?

This an exercise about fluids, in case water circulating through a tube.
My problem is when I try to render the animation, crashes! Whether it is in .AVI format or sequence of images .PNG or .jpg. Besides, everything works correctly. Could render the animation manually frame by frame, with f12, save and use the sequencer of the Bleder, but this is preposterous.
I wanted your help to know if it is the file that is somehow corrupted, or if the settings are heavy for my PC (I don’t think so, because renderizei animations well heavier, but who knows).
Who can download the file and try to render the animation and post the result, I am already grateful.
[TABLE=“class: kmsg, width: 1116”]


Please could someone turn my file to see if there are any problems with it or with the settings!! He has no virus nor affect the computer, it’s just a simple animation with fluids.
I need to know if the problem is in the file, in the settings or if it’s my computer power. So I ask the help of someone on this forum.
Thank you.

Says that there is no such file.

Hello, thanks for trying.
But it’s weird. because I’m on Google Drive and he’s there with the correct permissions.
I hope that anyone else has problems with it.
Again thank you.

The correct method for rendering an animation is to render an image sequence, then use the VSE to create the video file afterward. But you don’t have to render each frame individually. Set the render output type to png or whatever format you favor (I don’t recommend jpeg) and hit Render Animation. This will render the whole image sequence. Then assemble them in the VSE and render that animation with your video format of choice as the output type.

Aside from that, your file has some major problems. Your fluid domain is a tiny, tiny little spec of a rectangle tucked away inside the tube and hidden. All your fluid objects need to be inside the domain, so I don’t see how this is supposed to work. Additionally, you need to apply scales and rotations on your objects before baking your fluid sim. Ctrl-A in object mode, after you fix the other size and placement problems.

You also need to take that Smooth modifier off the domain. That’s screwing everything up with your sim.

Thank you very much for your contribution in relation to the parameters of my scene. However, I don’t quite understand about the issue of the size of the fluid domain ". The original scene was composed by domain, a cube surrounding the tube, the tube and the “transmitter” (inflow) within the tube. I made the bake and everything worked well, and the smooth modifier is necessary so that the fluid domain does not leak through the pipe (which had the application of ss modifiers, solidify [offset = 0] and edge split).

I tried to render the animation through images, both .PNG as .JPEG, to do what you suggested, but also so the Blender stops working.

I downloaded your file, and rendered the first 30 frames as JPEGs. Rendering frame by frame then making a video with the sequence editor is not only not preposterous, it is the recommended method.

At any rate, the frames render fine, but there seems to be nothing happening with the fluid simulation.

This is the first and the thirtieth frames.

I also ran an alt+a animation of 200 frames: nothing happens.

Thanks for the help.
But I don’t understand why no water flowed down the barrel. By chance the objects were not associated with fluid physics in the properties window.
The tube was not marked as an obstacle, for example? There’s only the tube and the lights? Everything disappeared? How is it possible?

Here it renders fine as it is. Render size was set to 25% and rendered 30 frames using h264 output with h264 codec. It was time ‘stretched’ what caused some ‘splashes’. These are not present on the original render.
Rename file to ‘name.mpg’

Edit: PC specs - pretty low, 5Gb RAM, GF560 2Gb, 64 bit nix.

Thank you very much, just getting interesting the overflows. I will try to use the same configuration used. But I would like to know what are the features of your computer. In your experience, what would prevent this rendering occur on my PC? Have a PC Win 7 64, i5 3570, 16 G. I use ssd instead of hard disk, this could affect the virtual memory usage by the Blender for not being prepared to use ssd devices? It’s just a speculation.

@eppo: did you make any changes to the physics settings? I downloaded the same file and just changed the animation output to render jpegs to a folder on my computer. Nothing happened. How did you get the simulation to work?

Your pc is much faster than mine - AMD, 2 cores, 3000+, and has a lot more memory. I do not think SSD has something to do with blender - it’s OS what makes it turn… On the other hand W7 has not so bad record concerning blending.
I did check older hardware successfully using Puppy linux live cd and freshly downloaded blender just to find out that XP doesn’t cut anymore :(. If you’re willing to experiment burn a CD and try. It doesn’t interfere with your existing win install.

At large, if you have 30 frames to render and know that you wont do anything else in compositor, provided that all is ok with your video coding, i usually render movie output. If that would need some further work - any appropriate image format - except jpg.

Did not touch any phys or any other sim settings. Only changed render size as it was taking a lot of the time. Then quick external software ‘expand of time’.
Do you have both layers selected? Fluid is on the second.

I described what needs to be fixed in order to get the fluid sim to work 8 posts ago, but it sounds like that advice has been ignored. So I’ll just refer you back to that and add the one thing that I missed: remove doubles from your tube. There are hundreds of duplicate vertices.

Ah, no, I just had layer 1 selected. but it did not help. My images now have that little ball in them, but nothing moves.

You have to rebake the fluid sim. This problem that was brought up happens to me sometimes when I don’t realize that I have some modifier enabled that is creating some obscene amount of geometry at render like, you start with 1m verts and forget you have 5 levels of subsurf at render and 1m turns into… carry the 2… uh… a really high number. And subsequently causes blender to walk off the job site.

Yeah I downloaded the file too and I don’t do fluid sims that often but shouldn’t the domain be at least as large as the simulated area? Its infinitely small in the file and you have 512 duplicated verts. I couldn’t get any fluid to show up even after baking. Every frame is the same.

@ BrentNewton
My domain, the initial cube, was a little wider than the tube and it was 1/3 higher than the height of the tube. Therefore, I think that the size was appropriate for the simulation. So much so, it typically occurs, the problem is in rendering.
I used the settings suggested by you. On the first try, he began to render pretty fast, but even the frame 40 and stopped.
Reduce the number of frames to render to 40 (thought in making various chunks of movie and then join them), but this time stopped in frame 36. Repeat the operation by disabling raytrace, leaving only ztrans, nothing helped, stopped, this time, 22 frame. With each attempt the number of frames rendered decreases.!!??

Except eppo got it to work. I expect he did something so obvious to him to make it work that it literally ‘goes without saying’. I wish I knew what that thing was.

@JOAGOSTINI: have you got enough disk space available to save the files?

I have 17 Gb free. I think that is sufficient to render this animation it must be tens of megabytes.

I did not check on double vertices and scale differences assuming that it would show up if this would be wrong, clearly ignoring K Horseman’s advice, which generally is true for the blending in a first place.
Have to say i was also in doubt it should work at all looking at what domain size was in file downloaded. However after setting bake cache path (as it was pointed out by BrentNewton; i forgot to mention this as it was kind of obvious) and selecting domain object in Outliner and re-baking sim just did work.
AFAIK as soon as you set fluid sim and try to animate, domain turns into fluid - it disappears as it was created before; another thing i consider weird in file since there it’s just a tiny cube inside the tube. Could be because of the lack of bake cache/path to it.
Anyhow, it did work and if i did something else my subconsciousness hides that from me. Did i bring that fluid obj to the layer 1?

Edit: further ignoring all what concerns blender’s modelling best practices, just moving sphere on layer 1 and re-baking sim on XP 32bit, Intel [email protected], 2Gb RAM using same direct h264 render (~1:40 per 25% sized frame): (rename file).

This is something to do with your specific OS settings/hardware, looks like. Can you bring up blender’s terminal window and see what errors come up; better yet start blender.exe from terminal window- if it crashes blender’s terminal will close too - (Run, ‘cmd’ Enter; cd where blender.exe is and run that).