Problem with the texture quality.

So i’m Modeling a simple wheel with half spheres for the ‘rims’ It’s something basic for a simple project.
I used the UV image editor to set part of the image to be used in the ‘rims’ area. The image was exported from AI at the highest possible quality. When I change from solid, to Textured, in the 3d view, the image looks great, but when I hit render, It doesn’t look great anymore. It renders at a lower quality.
I’ve tried lowering the filtering in the texture window, but that doesn’t work.
Anyone got any suggestions?
I also rendered with HD settings to see if that was the problem. It didn’t help.

this issue is being addressed in 2.5
http://www.blender.org/development/release-logs/blender-250/other-rendering-features/

Thank you!