problem with transparencies

I’ve been going through a tutorial that was posted by one of the memebers here (http://www.cogfilms.com/tutorials/Blender-Seascape-Tutorial.pdf), and I’m having some major issues with setting the transparency (this is with blender 2.36). I’ve set the world background as per the instructions, but when I apply the alpha transparency the entire scene renders as basically just the red world background. I’ve tried messing around with some of the parameters and nothing has worked so far. i believe the transparency is set correctly as part of the water plane, but maybe I’ve missed something. anyone have any ideas where this kind of issue would come from?

thanks in advance

Prehaps you could give us a screen shot of your settings, it would give us a beter idea of your problem

You may have the transparancy set to high.

I have heard others have got this tut to work but haven’t tried it yet and i can’t see any ovious problems.

Turn ZTransp on (or Raytransp).

I tried raytransp and it renders exactly the same as the scene with the transparency texture off. the ztransp helps a little bit, though things are still overwhelmingly red. I’ll post settings screenshots shortly.

alrighty, here are the settings (decided against the whole screenshot thing); I’m not sure what will be helpful and what won’t, so I’ll try to get everything that isn’t a default.

in the texture window:
texture type is blend (mat button selected at right), in Blend panel Diag is selected (preview appears as in tutorial)

in the Shader window:
Full OSA is on (didn’t change anything, naturally), in Mirror Transp panel IOR is 1, depth is 2, fresnel is 0, fac is 1.25, spectra is 1, add is 0. I kept these settings constant when using Ztransp and Raytransp. In the Map To panel, Alpha is selected (everything else is off), listbox below says Multiply.
In shaders panel, Traceable is on, Shadow is on, spec is .79, hard is 138 (as per tutorial), translucency is 0, amb is .35, emit is zero, and radio is selected. in Map Input panel, Orco and Flat are selected.

In World window:
Blend at right is selected, righmost color picker is on red (as per tutorial), in Mist/Star/Physics panel Qua is selected, in Map To panel Blend, ZenUp and ZenDo are selected, listbox below says Subtract. In Texture and Input panel, View is selected.

those are all the setting that aren’t default or that I thought might be useful. sorry for being such a windbag, but most of my materials experience is with 3ds max, so I’m getting used to the settings.[/img]

In F5, Material tab bottom right, set the material’s alpha to less than 1.00

%<

tried turning the alpha down, and the render got less water and even more red. makes me think that I’ve somehow got the textures mixed up, but I tried removing and recreating it, and got the same result.

Still would love to see some screen shots! especialy those of your transparenvy settings. the tut was made for an earlier version of blender so lacks some settings details. I could be something ovios you over looked, or clicked that you shouldn’t have. trust me we all do it…

all right, I’ll put some screenshots up. however, this being my first time on a forum (amazing, no?), I would assume I can insert image links to my computer and the images are then uploaded, or do I have to have the original source accessible from the web?

many thanks from a forum newbie

blender is very graphic heavy if everyone using elysiun post all their images and videos here we would have run out out of space long ago, as elysiun is a free service.

you’ll need to post it to another image site.

any suggestions of places to post?

try ImageShack or PhotoBucket, they offer free image hosting.

betten! :smiley: was searching the form that question comes up hundreds of times, all i can remember of hand though (since my search came up void) is http://gallery.mudpuddle.co.nz/ it aint half bad :wink:

ok, i’ve uploaded screen shots of all my texture and material windows over at the public blender gallery (http://blender.sixmonkeys.geek.nz/view_album.php?set_albumName=sillyfool)

I can see your problem one more screen shoot, the renered image. :expressionless:
hope you’ve come right.

ok, i’ve posted a couple of renders with various levels of textures turned on. with all of the other textures present and a little tweaking it isn’t nearly as bad as it was, though there is room for improvement (transparencie’s still pretty heavy). I’ve left the transparency color as red for visibility’s sake, though color change does help.

I could be wrong here, but your alphas been set by your texture. You can try to things

  1. the alpa buttons 2 faze, 1st is off, 2nd is the lighter the color the more transparent it is, 3rd the darker the color the more trasparent it is. by pressing the alpha button it will inver the transparency but may solve your problem

  2. Make your texture darker or lighter to decrease or increase the amount of light getting through.

I hope this solves your problem :slight_smile:

I’ve posted some renders now, though I found that with the later textures and the color change the problem is less noticeable (though still far from ideal). in the screenshots I’ve left the transparency color as red for visibility, and I’ve included some renders with later textures as well.

the alpha setting change seems to have helped a little bit. i guess the texture is just too heavy. thanks for all your help.