Problem with UV mapping

When I apply a UV map to my model, some faces are blackened and aren’t covered with texture. How do I solve this problem? I already tried to flip the face normal with ctrl-N but it didn’t help.

EDIT: Everything is fine when I render the mesh… the problem only arises in openGL viewmode.

Here is what it looks like (in UV face select mode, no texture visible):

http://membres.lycos.fr/coursguitare77/img18bug.jpg

Thanks!

you may need to apply copy draw mode to the faces?

Tell him HOW to do that tedi. Key strokes. Mouse clicks, menus selections e.t.c.

With all your faces selected, go to edit panels (F9) and look at ‘Texture Face’ Panel. At the bottom there is a button that says ‘Copy Draw Mode’. (You must be in face select mode)

Thanks I tried it but it doesn’t solve the problem.

I don’t understand what “copy draw mode” does to the faces. It only highlight them as far as I can see…

Ok! I found the solution. I deleted the existing UV coordinate by clicking editButton->mesh->TexFace->deleteButton and then I re-applied the UV map and everything is fine :slight_smile:

Thanks!

Hi, I’ve got some problem with uv-mapping too, I’d like to delete the existing UV coordinate to start from scratch, but I can’t find that deleteButton that you mentionned… where is it ??

Take a look at the screenie below in the mesh tab in the middle bottom area of the pic , where it says texface and a button next to it that says make , well when you have uv mapping done this button will say delete , click that and it will reset the uv mapping.

http://mediawiki.blender.org/uploads/d/d4/Manual-Part-I-Quick01v241-3.png