Problem with UV Mapping

Hello everyone,

I’m working on my project for the blenderguru contest.
So much is done yet.
But now I have a problem. I know, I’m not so good at texturing at all but normally I solve my problems.
But in this way I’m totally irritataded. I think this shouldn’t happen.

So the history:

  • modeled the book
  • apply scale
  • marked seams
  • uv unwrapping
  • adjusted the uv mesh
  • exported the uv layout
  • made a texture with gimp, saved as png and jpg
  • made a material, selected UV as mapping and the file as texture

And now… on the left in the uv mapper it looks great…
…but on the right it doesn’t fit


Everything in 2.62 and cycles.

What do I make wrong? Does someone know?

Greetings,
Nahuta

It would be in Blender Render and not in Cycles, i would say to check in the Texture panel, in the Mapping tab if you have modified the size X/Y/Z settings.
In the Cycle nodes, have you added some node that can modify the UV scaling ?

If nothing seems changed to you, can you upload the blend (with the texture of course) ?

Thanks for the answer.

This is the node-setting:


So I have modified nothing - a really simple setup…

Now I seperated the book in a new file and attatched it to this posting - with the texture. Perhaps this helps. Thanks! :slight_smile:

Attachments

Buch.zip (84.4 KB)

Looks like the source of the problem is the Bevel modifier, if i remove the Bevel modifier, suddenly the uv is correct.

To see what the Bevel modifier does to the UV, and so understand why it’s so badly displayed, go to Object Mode and apply the Bevel modifier.
Go back to Edit mode and look how horrible it makes the UV

A solution i can think is to apply the Bevel modifier and redo the unwrapping.

If instead of 2.62 i open your blend in 2.63 , despite the Bevel Modifier, it looks correct. It’s possible they repaired a part of the Bevel Modifier “destroy UV” problem in 2.63 , so maybe you should move your project to it instead of staying with 2.62 that has this problem

Jipppie! That’s it! Thank you very much! :slight_smile:

Yes, looks like a bug in 2.62 which is now fixed.
In times like these when I have a deadline of a few days whith the contest I don’t want to swith to another version. But after this I will do so.
But applying the bevel and redoing the uvmesh sounds good - I will do this.

You saved my day! :slight_smile:

Greetings,
Nahuta