Problem with weird rotation while trying to set curve modifer

Hello, I am having an issue trying to make a tube follow a nurbs path. I think it can best be explained with a set of pictures:

This is the direction I hope for the tube to go, I make sure to hit control-a and apply both the rotation and scale of the tube and of the nurbs curve before setting it to follow the path… However, when I go to set the curve to follow the nurbs path, it flips like so:

I thought maybe the problem was the deformation axis being along the x axis (even though the tutorial I was following he did not have to alter the deformation axis at all for it to work properly) but when I change the deformation axis to Y i get this:


You can see its going the right way, but it flipped on its side, changing it to -Y has a similar effect of it going the correct direction, but with the tube flipped upside down.

This is seriously driving me crazy, I am wondering if I messed something up in my blender settings by hitting some hotkey I didn’t realize or something because everything I have searched for to fix this seems to have the problem fixed by making sure the rotation and scale are applied before setting it to follow the nurbs path with the curve modifier.

Thank you in advance if anyone is able to assist me with this!

Attachments




no one? :frowning:

Hi pixelkraft!

I guess you were following Andrew Prices tutorial on tunnel modeling. It´s strange but it looks like the path tool no longer works like it did in previous versions (correct me if i am wrong). I have wasted 3 hours trying to make it work with path tool. No success.
Solution is very simple

FORGET about path tool and use bezier curve instead. It worked for me :slight_smile:

Hi pixelkraft!

I guess you were following Andrew Prices tutorial on how to model and render subway tunnel so as i. It´s strange but it looks like the path tool no longer works the same as in previous version (correct me if i am wrong). I found a solution after wasting three hours trying to make the path tool working. And it´s pretty simple.

FORGET about path tool and use bezier curve instead. It worked for me on version 2.77

Happy blending :slight_smile:

Hi

You can go Edit mode and rotate the object.

Set location is a good rule too I think…

Select Path or Bezier Curve Press Shift - s Cursor to selected…Select object Pres Shift - s selection to cursor.

And don’t forget to set Origin…T - Panel - Tools - Edit - Set Origin to Geometry on both.

It’s easier to help if You upload Blend file…:slight_smile:

Tai