Problem with wireframe modifier. Strange artifacts. Blender 2.81


I’m having an issue with the wireframe modifier in version 2.8 creating random geometry that is not part of the original mesh. This is not the first time I have had this issue. In this case my base mesh has been downloaded from Turbosquid (but originally created with blender), which I have edited, decimated and then cleaned-up. The solid body model and geometry look fine…

But when I apply the wireframe modifier it looks like this…

As you can see there is a lot of craziness going on here that shouldn’t be.

It’s not being caused by rogue vertices and I’ve tried everything I can think of to stop this happening to no avail:

I have applied all transforms, deleted loose vertices, merged by distance to remove doubles, reset normals and UV’s, deleted and reapplied the wireframe modifier and even exported the mesh as an obj and imported it into a new project, but nothing works.

The same issue occurs if you convert the mesh to wireframe using the the setting in the MESH context menu in edit mode rather than applying the wireframe modifier.

The problem only seems to affect certain models, I’ve used the wireframe mod with several similar models from various sources, that have been similarly edited with no problems at all, but this is not the only model I’ve had this issue with.

I’m running Blender 2.81 stable on Mac OSX High Sierra.

Anybody any thoughts on whats going on here, or able to suggest a fix?


Have you had any luck figuring this out? I’m having a similar problem. Modeled, looks great, try to add a material to part of the mesh and then it goes crazy. I can see the random planes that stick out are the color I added, but they have nothing to do with the model. Also I sometimes see infinite vertices surround my model but can’t select them, or get rid of them and think the two problems are connected.

check in N panel the size of your object !

there might be some verts far away

happy bl

@Seeking_Buddha Sadly I didn’t work this out, I ended up working around it. Since my final output was in After Effects I imported the model into element 3D and used its native wireframe material, which renders tris instead of quads as I wanted, but was better than remodelling from scratch.

@RickyBlender In my case the problem is definitely not distant rogue verts. I checked and triple checked for this.

I have had the same problem since with other models, but have yet to pin down what is different about them than others that work just fine when converted to wireframe.

Hey, could the issue be possibly because of scale and rotation not being applied?

@zodiac98177 Not in my case. All transforms were applied.

can you upload file

but i’m on 2.82 now and Win10 not Mac

will see if I get same error

happy bl

I have had this issue myself a few times with models of my own, it seems somewhat unreliable to pin down the issues but one thing it seems like its maybe connected to, is Even thickness on the Wireframe Modifier, i have noticed in a few instances that Turning that off seems to fix the issue, but it doesn’t seem to be a 100% fix as other times it changes it but does not fix the crazy verts.

I had this problem today. I do onow how to fix it, at least in my case. In the wireframe modifier menu, deselect the option that says " Even thickness"

1 Like

I gave up on that method for modeling for this character and switched to sculpting and I’m having very good results. I never did figure out what was happening. I just filed those attempts away.

I had this issue. Unchecked the even thickness and it solved the issue.

1 Like

Thats just overshooting. Put a weld modifier infront of the wireframe modifier and play with both the weld merge distance and the wireframe thickness values.

This is the answer. Its the combination of asking the modifier for even thickness and at the same time having the thickness value too high for sharp/constricted area’s in your model.

There are area’s where it can’t fit the wireframe with the thickness you ask of it. Normally it would scale it down in those area’s. When you deny the modifier that option by ticking even thickness you get the overshoots as a result.

Uncheck “even” and the modifier will solve it for you.