Problems Exporting Vertex Painted Mesh Model - No Colors on the Canvas

Hello Folks,
I am having some issues with Vertex and Texture painting. I originally split the mesh model and have a 3D view of the mesh and a UV/Image Editor of the flat canvas. I was able to paint on the mesh model, but the colors are not showing upon the flat canvas.
I know I split the model and unwrapped the mesh correctly (I believe so from my numerous readings) or I wouldn’t be able to apply any paint to the model.
Does anyone have any idea what I’m doing wrong or if there is a way to apply all the present colors from the model to the canvas?
When I export the files, the png file is a transparent canvas.
I’m using Blender 5.9 and importing to XNA 4.0 (which I’ve seen are compatible programs http://wiki.blender.org/index.php/Extensions:2.6/Py/Scripts/Import-Export/Blender-toXNA).
I’m not getting any compiler errors in VS2010 Express and when I run the program, all I see is the blue background. I’m following the code on this page: http://msdn.microsoft.com/en-us/library/bb197293(v=xnagamestudio.31).aspx

My mesh model has no bones. I want to make sure I get this correct before adding a skeletal structure.

Thanks again for the help,
Blender_Nube

It sounds like you are doing vertex painting when you want to be doing texture painting. Both are capable of painting on your model but they assign the colors to different parts of the model.

In Vertex Painting, colors are only assigned at vertices and then interpolated between vertices. Texture painting assigns the colors to a texture and then the texture is wrapped around your object according to your UVs.

Try getting into texture painting mode and see if that improves your results.


I’ve got to be missing something here, but I’m not able to apply any paint in texture mode. I can only paint in vertex mode.

It seems that I can right click and get a “custom” matching color displayed in the circle beneath the brush selection, but that’s about it.

Is there any way to clear the paint off of the vertices?

Painting the model a different color doesn’t seem to be a possible solution, at least at this point.

If it were, wouldn’t my vertices still be the same color even if I could paint the individual faces in texture mode?

Thanks again,
Blender_Nube

Here is a sample .blend file that is setup to do texture painting. You can check it out to see if it works for you and try to find some settings.

If that does not help then you would need to post your .blend file so I can look at it. I really don’t think that you should have to delete the entire model to get this working correctly.

Attachments

texture-test.blend (467 KB)

Thank you. I will check it out right now.

Later that day…

Your test file works fine.

I noticed you have a “Unique datablock ID name” for your UV file called “text”.

I have never imported or created a new picture from this part of the panel.
I only have a transparent, unwrapped canvas created from the mesh model.
BTW, I only see the canvas when I mistakenly hit the correct keys.

I vaguely remember viewing a video that showed the black screen in Blender’s UV mode, but never created this file because I had the mesh model’s unwrapped canvas to receive the paint.

I have obviously messed something up along the way.

I’d really, really like to know how to extract my model without the vertex paint being applied.

Does anybody have any Vertex Paint Remover? :D:yes:

Blender_Nube