Problems rendering VSE with speed control

I’m super new to blender but know my way around editing video well enough. I’ve put together a string of edited tutorial videos with slight speed adjustments to help with timing. Everything looks amazing in VSE but when I render, it’s like the speed controllers aren’t there at all. All of the footage reverts back to its original speed. I tried to read up on it and found blender doesn’t like different frame rates (existing video is 29fps trying to render at 24) and that it’s also tricky to apply several effects at once. I was resizing and speeding up at the same time.

To avoid all variables, I opened a new blender file, put in a single video, kept the frame rate consistent (at 29fps) and only added the speed controller by clicking Shift+A, add effect strip, speed controller while the movie was selected. I unchecked stretch video and added a speed modifer of 1.2. Then I rendered and got the same results. It renders as if the speed controller doesn’t exist.

What am I doing wrong? Please help!


So not really a solution or anything but I managed to find a work around that actually worked in my case. I figured it had to be something to do with the frame rates or format, so I put the footage into a fresh blender project and rendered it all into PNG images at 30fps. Then I opened a new blender project set to 24 frames per second and loaded the image sequence. I didn’t resize or anything. All I did was apply the speed controller and try to get the speed about where I wanted. I rendered that image sequence into a new PNG image sequence at 24 fps. (If I rendered it into an MPEG the timing was still off) I was then able to plug the new image sequence into my original movie project at 24 fps and resize, etc. Alot of hassle and probably an easier way, but that’s what I ended up doing.

Yeah Blender is VERY sensitive to source Codec compression. You need a very lightly compressed video file or preferably an image sequence… which as you state is a pain. Also try generating a TC file for the strip in the proxy panel.