Problems when texturing my model

I have created a model to use in Visual Studio 2008. My problem is about textures: if I choose “Solid” in “Draw type” it’s fine, but if I choose Textured, some faces are invisible!
Also, I have try to apply a texture, but I don’t know how to export it - I export in .fbx to can use it in Visual Studio.
Here 2 screenshots with the different draw type:
And >here< you can download my model.

Thanks for any help :smiley:

If certain faces don’t render in textured draw mode, it means the normals are facing backwards. so, provided it is not a compound mesh that intersects itself, simply select all vertexes in edit mode, and press ctrl N. Another solution would be to flip them manually, or set them to ‘2 sided’ in edit buttons.

Thanks for quick answer!
I have first “remove doubles” and after press ctrl+n. Now I have less “ghost faces”, but if I reuse ctrl+n some appears and some disappears again… But where is ‘2 sided’ in edit buttons ?
Thanks again.

Select the faces and press W->Flip Normals.
Also, you can turning display to GLSL mode (Menu - Game->Blender GLSL materials) The default display shows single-sided (but renders two-sided)

Good luck :slight_smile:

Sounds like you have an edge with three faces attached, or an inside face. In the 3d view, in edit mode unselect all and press ctrl+alt+shift M (or goto Select>non-manifold edge) the problem is somewhere with one of those edges. Double sided is in the edit buttons in the “Mesh” tab where you also change the object center and the UV maps and the auto smooth option. But that’s not going to help you here, mere mortal.

Sorry about that last bit, I just wanted you to get the proper feeling of helplessness. I should write a tut about the sneaky manifold face of doom.

Ah, you’ve got a link the the file hidden under there. You’re going to have to remodel some. The… headlights(?) in the front are faces on the inside and outside. There is also an edge in the front that connects on the sides. Disconnect your inside “box” thing with the outside. There is also faces on the crossways on the thrusters, you’ll have a hard time spotting all of these. (ctrl shift alt m highlights damn near every edge, heh) If you need it, (I’d rather you do it on your own) I could mail you the model with the extra faces removed and the original file with all the faces uploaded.

Also, You could get a lot more thrust with vortex thrusters. Sorry, had to nerd out there.