problems while trying to install blender on a laptop

Hi :slight_smile:

I tried to install a blender binary (after trying in vain to compile blender
for cygwin from the sources - see later in this email) and have (between
others) the “mini icon problem” mentioned in
Which is to say: the icons are not displayed. At their places are just black
squares, all looking the same…

I tried to find some new drivers following the instructions in
but … there was no information in the documentation of my computer
about the chipset. I have a MEDION MD 9580-F laptop computer
bought in October 2001 (…for German readers: I bought the computer
at “Aldi” :slight_smile: which was good enough to run Maya 4.0 without any
major problems. In the display properties dialog
(in German: Systemsteuerung > Anzeige) under the settings tab (Einstellungen)
I found the following:

  1. (Standardmonitor) mit ATI RAGE MOBILITY-M! AGP (DEUTSCH)
    which translates to something like:
  2. (standard monitor) with ATI RAGE MOBILITY-M! AGP (GERMAN)
    but couldn’t find any information about this card at the ATI web site
    ( ). After searching for a possibility to contact ATI by
    email for about one hour in vain I gave up and decided to never buy anything
    from this company again.

Is there anybody who could help me - or who was able to install Blender on
a similar laptop??

Thanks a lot - especially also to all those people helping to develop blender -
and best wishes from Tokyo, Dietrich

Here some more problems I encountered when starting blender - for the
case they contain some helpful information:

  1. a small window with the following message is shown:
    ERROR: File “.Blanguages” not found

  2. a windows command shell with the following messages popes up:
    ‘import site’ failed; use -v for traceback
    sys-init: warning - no sitedirs added from site module.

  3. the menu window on top and the vertical lines in the scene panel are
    only shown after minimizing blender and maximizing it again.

  4. the mouse leaves traces in the menus

When I tried to compile blender from the distribution using cygwin and
the advices at
the installation process went fine. Only when I tried to start blender
a window popped up informing me, that “SDL.dll” couldn’t be found.
Searching for “SDL.dll” and moving it to all kind of other places
(system, system32, the blender bin directory - thanks to the help of
the “appleman”, thank you!) where rewarded with another window stating:
“couldn’t initialize the application (0xc0000022), please push
“OK” for exiting the application”
(in German:
“Die Anwendung konnte nicht richtig initialisiert werden
(0xc0000022), klicken Sie auf “OK”, um die Anwendung zu beenden.”)
… not really helpful…
Any hint??

…Ah, one more question: what is a “Poll” - that thing elysiun asked me
to add to this message
…one more: is there a blender user group / forum / etc.
for people living in Tokyo??

I didn’t read all of your post

but anway

is this your own build? The working directory of the offical build installed with the installer should contain that file. Usually, when you see this error the window will need to be resized for the info header to show up.

the console will always be there when blender is running, but you can ignore that warning. The warning should go away if you install python 2.3.x

I think that is part of the .blanguages problem

try disabling the cursor shadow [in mouse properties], and also try changing your color depth for your display to 16 bit [this fixes most graphics problems, sometimes even better with newer drivers]

nope, no idea

when you create a new thread you can make it a poll… and stuff

Hi :slight_smile:

Of all those problems mentioned, the “mini icon problem” actually was the worst:
seeing only black squares at the place of icons I couldn’t orientate myself
in the user interface at all…

Reading the instructions in
again and again I finally tried different settings ---- And was most happy when
it turned out that a color depth (see the link above) of 24 bit solved all my problems :slight_smile:
(…not all of course but the only real problem: the
black-squares-at-the-place-of-icons problem…)
As I had read that Blender usually preforms best at 16 bit I never had tried to
experiment with this option before.

Concerning the rest of the problems, I got accustomed to them very fast
and didn’t bother to change them any more…
A little while after - because of a couple of other problems - I switched to Linux where
everything worked (nearly) without any problem from the beginning :slight_smile:

( Actually I again found a small window with the message concerning the
“.Blanguages” file but found this file in the directory, where the blender executable was
located. by executing blender form this directory it could find the “.Blanguages” file.
I also didn’t like blender filling the whole screen but the option “-w” helped.
To make things easier I defined the following alias (bash, only in unix, linux, cygwin, …)
to start blender:
alias blender=’( cd /…<path of blender binary>…/; ./blender -w; )’

Concerning the other mentioned little problems while still running XP
I dealt with them in the following way:

  1. the .Blanguages file not found:

    • after minimizing and maximizing the Blender window once Blender never
      asked me again for this file (thank you, z3r0 d :slight_smile:
  2. the shell window and warning - I ignored both and never had any problem with them
    (thank you again, z3r0 d :slight_smile:

  3. the upper menu and the vertical lines

    • after minimizing and maximizing Blender the menu was there and so where
      the vertical lines
  4. the mouse traces - didn’t vanish even after disabling the cursor shadow
    but didn’t disturb much anyway

  • the drivers - everything worked fine with the original ones after changing
    to a color depth of 24 bit (all other color depths didn’t work with my environment
    and Blender, which - of course - should be different for other environments )

  • the installation from the sources - for the moment I was happy with the executable
    working and postponed an installation from the sources until the moment
    I really felt like messing around with them :slight_smile:

Thank you, z3r0 d, for your help and detailed answers !!!
(Thank you, blenderanim, also :slight_smile:

i have downloaded it to my del laptop and it ended up crashing i hope it wasnt a bug in the blemder 2.35. i will reseach into these problems

Sorry, I didn’t read your whole post, but I did note that your notebook has the ATI Rage Mobility M1 chipset. So does my Sony Vaio Notebook. I did a search here in elYsiun and the work-around for the “no icons” problem is to change your display settings to a lower color depth. Mine is set to 24 bit and Blender 2.35 works fine.


Hi, …with my last mail I actually wanted to say that a color depth of 24 SOLVED
my problem - for the case somebody else would find my first mail and be
interested in its solution…
If I hadn’t solved it yet, I probably would have by reading your mail :slight_smile:
Thanks, Dietrich