problems with alpha animation

I m trying to make an object disapier on 2.5x version of blender, but It look like I simply cant do that. My object have a texture, and on the 2.49 version of blender I could make it desapier with the texture but on 2.5x the object turn black, it desapier, but it dont show the texture that I put on it, Im using GLSL.
Here is an image showing the problem it should look like the image on the right but it look black like the one on the left.


Have you set a Material with the Texture added in the Texture Panel next to the Material Panel?
(And don’t forget to make the Material transparent if Disappearin’ shall mean to let it fade out.)

I add a texture to my material, yes.
and it have ztransp too, the object fade out and in again if I want but the problem is that it s black instead of that gray texture that you see on the image on the right.
but thanks C.A

Woah, there seems to be another thread in the Game engine resources section, and that got me confused.

My reply:

You want a transition, right? Or do you want a sudden change?

Logic Bricks can toggle visibility with jarring suddenness, but if you look at C.A. Ligari’s dissolve burn texture, you could try an animation.

Animated textures are tough for me though, and seem to need GLSL. You may want to try updating the drivers on your Gfx Card manually…

Thanks Satoru but that is not the problem,I want it to fade smootly from the image of the right that is a BW kind of cloth to transparent( this ll show the image that is the same as that one but with collors), and I want something light because everything for this game is beeing calculated. I really want to know how to make my texture appear instead of have that black weird thing like on the image of the left!

Okay, I’ll try to duplicate the problem on my version of blender.

Thanks Satoru

Try clicking the Object Color button for the material.

That is what make it black, it fade out properly but its black instead of with the collors, anyone had tried to use a texture to see how it behave? its weird why on 2.49 it works and on 2.5 it doesnt… I pressed a lot of buttons and unpress them but there it didnt worked.
But thanks solar lune!

Oh, also add a keyframe for the object’s color (I-key over the material’s color).

uhmmm, that I didnt made, I ll try here, thanks solar lune!

Thanks a lot solar lune it worked!!!

Wow… so if I understand correctly… object color don’t work - but if it’s turned on and have a animation it make a texture work???

It’s good things can work but this sounds like a bug all the same :-/ … or can someone explain whats going on?

For object color animations (like fading an object out), you need to have a keyframe for the object’s color, in addition to one for its alpha setting. Kind of a bug, but it makes sense when you think about it - you need the color to see the object correctly, as it’s modulating the finished material color and alpha result by an internal object color property, I believe. You could also use the object.color Python property to fade things in and out.