Problems with alpha mapping in blender render

I have been using cycles so I havent been using blender render for a while but I was making a scene with a alpha mapped tree off of cgtextures.com. How I have been trying to make my tree show up without the rest of the picture showing up is by checking the transparency box on Z transparancy setting alpha to 0 then checking premultiply in textures and checking the alpha option. But when I render it seems to make all the black in the image transparent making everything transpapent-like even the tree itself and I get the shadow of the plain not the tree showing up on the floor and other objects.

Does anyone know how to correct this or if there is a tutorial to do alpha mapping in blender render?


There’s a picture what’s checked, when you have png with alpha chanel inside.
Oh, and check Shadows - Receive transparent for a floor object…

YES got it working. Pronlem was I didn’t check use alpha and shados wasn’t checked on floor.