Problems with alpha

Hi everyone,
I wold like to make a double layer of mountains on a background scene. To do that I UV mapped the first layer (plane) with a picture with alpha channel (the sky) and choose Alpha.
The result is that in the 3d windows I see the second layer behind the tranparent area of the first, bat as soon as I render I just get the first picture with all the black in it (and some white).
I probably miss something that shoul be obvious, but I can’t get it.
Can anyone help? Thanks!

Add a Material in F5, and a Texture in F6. Choose “Image” type texture and from the little menu select the same image you UVMapped. In that tab click “CalcAlpha” to read the black as transparent. Go back to F5 and in the MapInput tab change the mapping from ORCO to UV and in the MapTo tab click Alpha.


Thanks Fligh, it’s a bit tricky but I will give it a try.
Nevertheless I do not like the use of a normal texture just because it does not allow the direct viewing in the 3d window- if I’m not wrong I have to render every time to see the results. As I am in need of giving a certain position to the layers, this will take quite a moment to get it right.
Don’t you know any other means to achieve the same result (other than UVmapping the picture on a mountain-shaped plane?).
Also, according to you, why the UV mapping cannot properly render the alpha although it has a specific button for that? (Opaque, ???, Alpha)
Thanks for being so supportive.

The UVEditor was originally designed for the GameEngine (rendering to OGL) and the Material Textures for the RenderEngine. So, if you want transparency in UV mode you need to use an image format that supports transparency (.png .tga etc). However, using both, the Material Texture will calc black as transparency and map it to the UV Coords and (if you don’t remove the UVMapped texture) if you click “TexFace” in the Materials tab you will still be able to see the UVMapped image in the viewport without rendering.
Setting the same image as a Texture in Materials just allows you to render it properly while keeping the UVMapped unwrap.


Thank so much for the explanations. Usually in forums one just gets “click here, click there” and remains utterly ignorant about the principles so remaining unable to apply it in other occasions. Thanks again.
When I started this scene I was using images with an alpha channel (.png) made with GIMP. I probably have missed something because its there that I had no trasparency at rendering. I post a couple of images here, one is a shot of the 3D window (transparency is there though the image in badly contoured on purpose) the other is the rendering of the scene. You can see I have black and white bgnd instead of transparency. Probably you can detect what kind of mistake I am making. Thanks again for any suggestion.


If your Images support Alpha (.png does so this should work) use Premul in F10, Render tab, instead of Sky. You can use Key instead but read the tooltips to see the difference.


Thanks for the suggestions Fligh, but they seem not to work. If I use the images UVmapped, the Premul or either Key do not change the situation. In the 3d Window I see transparency but not in the Rendering. Anyway I will use an Image texture instead of a UV map and the problem is solved.
Nevertheless I am left with a bit of unsatisfaction because the “problem” remains. To be clear, my image is one with transparent background. I wonder what will happen if I add a real alpha-channel (black) for trasparency in the original image. Do you think there will be any change?