Problems with blender cycles engine render?

I tried to render a video of water slowly being poured into a glass cup.

In some frames during the rendering process, a glass spike appeared out of no where, in the downwards direction that the water is pouring (into the glass cup). I do not know if this is a settings problem but it seems to pop out whenever I try to render and at different frames. Sometimes it disappear after one or two frames.

The problem is that I did not see it in the wire frame or solid mode when inspecting the timeline.

Anyone have the same problem?

that is the spike I was talking about, first time using cycles.

Is the spike coming from the centre of the glass? If so it might be a modelling issue. Looks like the kind of thing that happens when vertexes get pulled accidentally.

I don’t think so, it seems to follow the liquid that is being poured into the glass later on.

Come to thinking of it, could it be because I scaled the glass a bit bigger after baking the fluid simulation?

Perhaps a quick test without the glass?

Well, I tried re-baking the fluid simulation and not scaling the glass anymore but it still happens, though frequency is reduced.

Hmm, better wait for some expert advice, this is way beyond my experience. Hope you get it sorted out, I’m curious too.

For now, I can only render and remove the specific frames. By the way, how to you change the frame rate of the fluid simulation to about 35 so that I can cut without any lag in the final product.

Weird, I re-modelled the whole thing from scratch and use a different shape for the cup and baked the fluid witha different velocity, but it still happens. My gpu is not supported (nvidia 9500 gt, cuda version too old) so I was using my cpu (amd phenom IIx4 810) to render, not sure if it has anything to do with that.

I assumed the frame rate of fluid is governed by the animation rate in render settings. I’m also assuming in my limited experience that ‘fluids’ are ‘skinned’ particle clouds.

Incidentally, have you tried another renderer?

Should I just report this issue to