Problems with camera view

03 Breakable 01Aaaaa.rar (960.9 KB)
I’m new to Blender and I’m having trouble with camera view in the file I’m working on. So what happens is, well, several things.

  1. The camera doesn’t show me the aspect ratio (rectangle thingy showing me what cameras sees)
  2. Solid and material preview don’t show me what camera should see. Only Render viewport shows it.
  3. When I first switch to Render view it shows the picture distorted. However when I exit camera view and return in it, it shows the image correctly.
  4. For some reason my mouse scroll zoom in and out as well as translation stop working in camera mode. Only turning works.

When I open another file or I use the default cube everything works. The previous version also work. Only this file for some reason doesn’t and I’m at a loss. I’ve also attached the file if anyone can make anything out of it.

On the right view hit Home… You may had moved the view out of the way before setting Camara to View or hit accidently Ctrl-Alt-Numpad-0 (which curriously doesnn’t work for me)… ??

Thanks for the reply, but nope, none of those. Still doesn’t account to why camera works in Rendering mode and doesn’t work in Solid and Material preview.

Did you try switching the camera? Also, when a file has funny behavior, and I can’t fix it, one thing I will try is to append the whole scene to a fresh file, which sometimes fixes the issue.

You don’t have the camera selected according to view 1 or 2…to view the aspect ratio the camera must be selected…Usually just Hitting zero on the Numpad will do it if not then selecting in the outliner and then hitting zero…
Hitting the Gizmo should preview your camera but also doesn’t select it…

The distortion was from not having your ratio set 1:1 you have it scewed in the Y…also a 26 mm lens will add distortion…Camera shift will change things yours was shifted again to the Y … all of these things change what is rendered vrs. what you see on screen…

Hmmm :thinking: sorry for me this works (used 3.1.2 before but now explicitly used 3.0.1 (file version)… and i’m on linux): in the right view i just hit Home(another thing is using the View → Frame All from the right menu moves the camera on the left view…?? … okay this may be a bug) … ups sorry 4. (scroll, translation, rotation of camera while in view) works for me also but didn’t record :

Here is the Material Preview (no disortion, also switching to user perspective just works but isn’t needed to get rit ):

And rendered Preview… :

but also weird: there are two different focal length: if the left is set to camera with (Numpad-0HomeN)

Thank you all for the quick replies. Home key and “Frame camera bounds” helped/ solved the problem. However I still don’t understand why it didn’t work in the first place? How did it go out of bounds so only rendered view showed the bal? Why couldn’t I translate the camera? This is the video I did to demonstrate the problem.
I mean, it’s great that it worked, but I don’ get what went wrong in the first place.

Thank you. It’s still a bit of a blur to me exactly what went wrong. If camera wasn’t selected why would Rendered view show the ball and material and solid not? In that case I wouldn’t be able to see it in any instance right?

Yeah… i also don’t understand how you did get there… :person_shrugging:

I dunno, maybe I should perhaps post it in technical support or something?

The problem is: nobody can explain how you get there… i once thought i could be a problem because of the different focal length in the two views… but after a while i couldn’t reproduce the behaviour i thought i saw… a weird thing is what i said about using the right menu and on the left the camera moves forward ??? That’s is reproducable and may also lead a developer to the discovery of another bug that explains those other behaviour?? (I do think using Camera to View in two views just may be problematic…)

1 Like

Yeah, I don’t get what was going on there either…but @Frostensen was trying to do all that with a single camera,

Edit: Got this mixed up with another thread…but was referring to the Views he was showing…Where there are 2 viewports…1 camera…but you can select Camera to View in 1, and not select it in the other and get 2 different results…
I need to look at this further…not enough coffee yet!

Stored Views? Wasn’t that in another thread?
Edit: i mean this one Clicking on saved view box sets a new view instead of bringing me to the saved view - #7 by RSEhlers .