problems with compiling blender under MingW


 I am new to this forum as a member. I have a couple of questions to ask:-
  1. this question regards compiling blender on win32.

I thought it would be nice getting involved in the development of blender. however, after I downloaded the source, I couldn’t compile it.

I am using: MingW compiler 3.3 /w or w/o Dev C++
I have followed the instrructions provided with the source code and specified MAKEFLAGS and NANBLENDERHOME. however, Is till cannot compile the code, because make doesn’t seem to be able to locate the files. when I run make, ir gives the following errors:

make beginning in /source/blender/creator.c
/source/tools/guess/guessconfig: no such file or directory.
/source/tools/guess/guess: no such file or directory
make leaving /source/blender/creator.c

I tried it with MSYS 1.0 and it still doesn’t work, even with the POSIX system emulator.

I have searched the forums and the bf-committers boards, but I don’t find any information or documentation provided very useful to my problem.

I am currently running WinXP Professional OEM. Is it sth. wrong with the OS?

Could someone pls help me?

  1. this question regards accessing blender cvs.

Dev C++ has an access cvs option, which requires the following:

access-method : pserver, local, ext, sspi




remote directory:

I know the access-method is pserver, and the user is anonymous, and the remote directory is /cvsroot/bf-blender/, right? But I ahve no idea what is the port number?

Also, Dev- C++ requires the following, which I have no idea what they are: :frowning:

module name



Could someone pls tell me what to enter? :-? :-?

I would really appreciate it…


the (semi-desperate) arixion