problems with control J

so I make all sorts of bits then join them with ctrl-j
then in another file I append the joined thing.
yes everything was joined but they don’t all get to the other program (blender)
and when I have a picture on a cube, weird things happen when I join it to other things.
any ideas anyone
thanks

This is so vaguely described as to be worthless. Give an example. Show us a .blend file with a joined object that doesn’t append correctly to other files.


here is the problem
see the differences
on the right is unjoined
on the left the picture is distorted after joining with the cube.
thanks

Attachments

TESTOFCTRLjPACK.blend (554 KB)

If you have an image texture like that, why would you not UV map it?

never got UV to work and I should not need to if blender worked right

UV mapping is the proper way to map an image like that onto a mesh. If you can’t get that to work you need to learn how.

then why does blender have the facility to do it the way I prefer?

What do you mean “the way I prefer”? You prefer to use the wrong tool for the job? Don’t try to use a hammer to saw a board and then complain that it won’t cut right. UV is the proper method to map that image onto that mesh. Generated coordinates are for a different purpose entirely.

then why does blender ALSO gave the method i use?

generated is the mapping technique used for mapping generated textures. not image textures. hence the name. it’s not there because the Devs thought some people might prefer it

I’m stunned that you have been an user for so very long and yet have not used UV mapping. That’s not a criticism, it’s obviously a reflection of you using Blender for some very narrowly focused and specific purpose that has worked for a long time.

The problem you are having is the joining. The generated mapping method can’t deal with the complicated shape you have given it and distortion is occurring. One or the other has to change - either separate your objects or UV unwrap them.

If you are only using cubic objects you are right no UV unwrapping is ever necessary. But only cubes.

Here’s an example.

Attachments

TESTOFCTRLjPACK.blend (1.15 MB)

anon125 do you want help with your problem, or do you just want to argue with people?

glad you have a connection with the developers.
but i think this thread should stop. as there is so much confusion etc

I have done UV many times. but i still prefer the other option blender includes.
the complicated shape is a simple cube!
thanks

No it isn’t. You joined the simple cube with other things. There’s a cube mesh, but not a cube object now. Generated coordinates with cube mapping means that Blender is expecting a whole object that is just a cube. It’s not just a cube anymore. You joined it to something else. Now that your object is something other than just a simple cube, you need to use UV mapping. It’s as simple as that. Quit fighting with people who are trying to help you.

thanks
must learn to do UV again- maybe it will work for me now