Problems with Display on Ubuntu 9.04

I just installed Ubuntu 9.4 (with all available updates) and Blender trough the default package manager.

Whenever I start the application, the screen is messed up:

  • There are some weird trailing artifacts on the bottom and top of the 3D window
  • The default sphere in the materials panel is squashed
  • There are no icons

This is what I tried so far:

  • Disabled all GUI effects in Ubuntu
  • Run the application both in windowed and fullscreen mode
  • Tried the newest version of Blender, by downloading the default .deb package for Ubuntu 9.4. Same problems.

I run the application from command line using “LIBGL_ALWAYS_SOFTWARE=1 blender”. (I found it on some website) This fixes the problem with display, however makes Blender very slow.

Technical details of the machine:
http://vaio.sony.co.uk/view/ShowProduct.action?product=VGN-FS315E&productFilters=retired&site=voe_en_GB_cons&pageType=Overview&category=VN+FS+Series

Intel Graphics Media Accelerator 900 with 128 MB max. Dynamic Video Memory shared with Main Memory

Sounds bad. I take it this isn’t accelerated Nvidia? For 3D you really need something with high graphics capability.

I installed Microsoft Windows XP and run Blender on it. It works very smooth and fast.

“LIBGL_ALWAYS_SOFTWARE=1 blender” makes the program run properly, but slow. From what I’ve read this command runs the application in software mode.

So I guess the problem seems to be with hardware acceleration on Ubuntu 9.04…

have you got an Intel chip? I have.
if so, take a look here http://ubuntuforums.org/showthread.php?t=1130582
Go for the Bleeding-Edge Configuration, it worked for me

I’ve got an Intel GMA 4500HD and I have the same problems.
Like LPT said try the bleading-edge variant if you dare :smiley:

Seems to me like it’s a problem with DRI and XUA.
Blender worked correctly when I disabled DRI and set AccelMode to EXA.
But don’t bother trying. Even with this “high-end” graphic chip from intel the preformance is to poor with this settings. You absolutely need DRI and XUA (from what i’ve experienced)

the only thing you can do is install the newest mesa-dri and xorg-intel packages.
And a kernel capable of kernel mode settings is worth a try (maybe).

Anyways, I will stick to windows till the next kubuntu release which will hopefully resolve the problem.

bye

Oh this just sucks!

Anyone solved this issue? I have Ubuntu 9.04, Blender and an Inspiron 1200 and getting exactly the problem described by qumah!

Anyone know if there is a way to resolve this yet?