Problems with Heavypoly Config using latest build

I am trying to use the Heavypoly config from @heavypoly in the latest build (2.79.6). It’s installed as directed, and the interface has changed, however none of the keyboard shortcuts seem to do what they should, and the pie menus do not display. I noticed in the install video the version is something like 2.79.4 - should I roll back or with the issue be fixed? Also, how do i get a slightly earlier minor build?

I believe vaughn has switched to 2.8. he doesn’t maintain multiple configs, just shares the one he’s currently using.

Yeah, thanks, after quite a bit of googling i figured as much. Seems a bit glitchy in 2.8. Ive been messing with it, and I know 2.8 is not done yet so I cant really complain :slight_smile: It throws errors when i do the inset boolean to make buttons. Im following his Braun video. Just have to wait i guess…

Are you downloading 2.79 from here? The regular build won’t work properly.

For 2.8, the latest can be found here:

@heavypoly Yes, thats the video i followed. I grabbed the most recent 2.79 which had a point version of 2.79.6. In your video for the 2.79 version of the scripts, I noticed your version number was something like 2.79.4. For me, loading your start up blend loads the custom interface but none of the keyboard shortcuts or the pie menus work.

That led me to try the 2.8 version of the scripts, on the lates version of 2.8, released on November 12. I am on a mac (High Sierra).

It seems to work but the live boolean is a little glitchy, the symmetry tool doesnt always go in the right direction, and the boolean inset tool you use about 20 minutes ish into your Braun video for that first round button throws a script error. I get the error again if i then try the other boolean tools. The regular boolean seems to work if i steer clear of the inset boolean tool.

Also when you start to make that button you selected two forward facing faces on the main body of the object and then use the pie menu to make a circle at that position, on those faces. Then in the video you hit S to scale it and it scales equally in place. this does not happen in 2.8, it scales but it also moves back as it scales, i think because the origin is in the center of the scene. I hope that made sense. Happy to make a little video to show what i mean if it helps.

The custom interface also does not quite match you instal video for the 2.8 version - looks like a panel is missing in the bottom right of the interface. the text area showing the keyboard shortcuts stretches all the way down, rather then taking up the middle third.

To clarify, there are 2 versions of HP config.
The video above only works for Blender 2.8
For 2.79, use this https://gumroad.com/l/Intro_To_Blender or the scripts from the corresponding video.

The 2.8 configs are being updated daily, the one you describe is the most current.

This is also just for testing / users already comfortable with 2.79 version of the scripts. More detailed videos covering how to use the 2.8 scripts will be coming soon.

Sure, understood. I am definitely using the right version for the right blender :slight_smile:

Here is what happens when I use the Symmetry on 2.8… totally goes in the wrong direction!

Totally get this is all very new stuff… im just trying feed back because I already like very much and if i can help iron out any bugs, i would be glad to do so.

EDIT: I figured it out. This isnt mentioned in the video, but after creating the cylinder, I hit D to increase the faces to 64 and used the rotate in that panel to turn it 90 degrees. If i then pull those faces out and do the symmetry, it actually goes along Y not Z.

The solution was to apply the rotation and scale after creating and rotating the cylindar. Once i did that, the symmetry tool went in the right direction. This was in Blender 2.8 released today.

Yup…mirroring respects object transforms

@heavypoly Ok so how come my screen does not look like the layout you have in the install video you posted above? I am on a Mac. This is what blender looks like opening it for the first time after installing your scripts… the panels on the right hand side are different, and none of the little plus buttons in the corner of each panel open the properties panels, they all do nothing when clicked, so I have to use the pie menu to do stuff. Theres no error reported on the bottom edge of the window when i click them. This is the latest build of 2.8.

you have to create a folder called “config” in your blender directory (next to the scripts folder) and drop the startup.blend file in there.

Yup, i have totally done that (and have done it several times). This is on a Mac. I get the exact same result on Windows 10 as well.

it’s possible you have another startup.blend overriding it. When you start blender for the first time, it creates userprefs data and whatnot in whatever location your OS stores that sort of thing. On windows it’s %appdata%/Blender Foundation/2.80/

See if there’s something like that on your mac and if so, check to see if a startup.blend is in there (if so, delete it)

1 Like

Thanks but I tried all that already - no luck. I have seen a couple of threads to do with 2.8 not correctly drawing the window on very large screens. My screen is 3440 x 1440… i’ve got hunch that its actually working, but perhaps blender isn’t liking the screen size and is possibly drawing the panels outside of the visible area.

I even ran a tool for the mac that finds all data to do with an app and deletes it for you. Its quite useful - AppCleaner

I’ve also never had Blender installed on my Windows 10 machine (I only use it for games really). I use the same screen.

i’m on linux primarily, (with windows in dual boot for the odd time I need adobe) with a 4k monitor… everything working correctly here with the latest 2.8 nightly. could be something specific to video drivers or something maybe. Might be best to wait until Beta try, and if it’s still happening submit a bug report when they open it up

This is how it should look with latest scripts, you’ve got it installed correctly

Heh… after all that :slight_smile:

Thank you, I stumbled on this after a lot of searching. The 2.79 config videos don’t actually show how to install the config. so I used the 2.8 video, but it never mentioned the config folder part, and especially the appdata part you mentioned. I deleted that startup file and I’m cooking with some sort of fuel now!