Problems with mesh animation and hair particles

Hi there.
I’m animating my mesh trough shape keys and I’m trying to create some eyebrows using hair particles. The particles are on a separeted mesh, but as you can see, once I animate the mesh the particles rotates as if it is following the mesh normals. Is there a way to avoid this?

Thanks!

check the checkbox ‘use modifier stack’ in the particle system. make sure any subsurf levels are matched 1/1 or 2/2, but never 1/2. If that doesn’t work post a simplified blend.