Problems with objects and the headers

I’m new to blender and I am currently using Blender 249.2 for a specific reason. I am having trouble when I add new objects. I can’t see the object nor seem to grab it, but I do see the name of the object next to the axis indicators on the bottom left corner (ex. armature.01). Also I am having trouble with the headers and was wondering if there is a way to restore them to the default without starting my project over. I appreciate any advice on the situation and will try to help you if I learn something,

When you add objects they are added at the location of the 3d curser. If the curser is out of camera range so will the new object. To reset the curser back to the centre use Shift+C. Then try adding your objects. Note that any previous objects you tried to add will still be present. Select them from an outliner window and then delete them.

What do you mean by headers ?

Well I thought that too about the cursor, I tried shift+c and added some things but they still didn’t show. I can see the objects name but i can’t manipulate it. It’s weird like it sees the image was added but can’t show it or something. I’ll keep trying other things. The headers I think I figured them out. I didn’t realize that you can change the purpose of each header bar.(ex. make one buttons menu and another the 3d view). I accidentally changes the two without seeing it.