problems with paths for plugins in vista

Hi everyone, im very new to Blender so please bear with me! I have successfully installed blender and python and got the ‘found python’ message on loading blender. I have also downloaded some plugins but dont seem to be able to get blender to load them even when ive written the paths in full in the preferences panel…can anyone provide me with some guidance on how to set up plugins … I have located the hidden blender default file location and tried putting the plugins, sequence and texture folders there and also writing the paths out in the preferences panel but every time i try and load a texture plugin (from the texture folder) the program gives me an error saying that the plugin doesnt exist at the specified location even though i know it does…any help resolving this issue would be greatly appreciated

take the easy way out, download meta’s build with all the plugins and scripts already included unzip it to where ever you want, right click on the blender exe and create a shortcut so you can easly launch blender from your desk top, plus everything is where blender expects it to be.

http://www.cdupload.com/files/45801_dzyzl/_blender-2.48a-windows.rar

tried downloading meta (your link didnt work by the way) and the version of blender used isnt the one im used to plus i have the dificult pathing set up so python works, just need to know where to put plugins and what to put in preferences to get them to be accessible… if anyone can tell me i would be grateful - this could be a vista problem as it generates a hidden file location valled Blender Foundation\Blender where it assumes the files are … i had to change permissions to be able to delete it and put all the folders in the same location as the program folder .blender where it makes sense to have all the data but as im constantly finding with blender ‘what makes sense isnt usually the way its done’ I have set the paths in preferences, program can find the folders and the files but keeps telling me they dont exist…tearing my hair out here…please help. Others must have had the same problems with vista (vista64bit o/s)

sorry about the bad link. http://graphicall.org/builds/builds/showbuild.php?action=show&id=1060 should work. you wont have to worry about python paths, it has full python 2.5.2 included inside so it uses it’s own pathfile and it works.

oohhh i see you are useing 64 bit. have you updated the menue yet? go to the scripts window there you will see the word scripts right next to the little snake in the left hand corner. click on scripts and a menu should pop up, at the top will be update menu, click on that and see if that works.

The word ‘plugin’ is somewhat ambiguous expression in Blender.
Sometimes it involves python script, and 3DCONNEXION’s 3D mouse driver need plugin installed in Blender’s plugin folder.

And sequence and texture plugin, they do not use plugin folder at all. *
(It seems only used by people who compiles plugin.)
When you want to use texture plugin, you first select Texture Type as plugin from Texture panel’s Texture select menu.
Then open a dll files from plugin panel’s Load plugin button.
The plugin’s located path is not restricted to anywhere.

But if you save .blend file that use texture plugin and open it again, probably you need reselect plugin.
This problem can be solved if you put that texture plugin at Blender’s app folder(where blender.exe is located) on windows.
If you use Linux the place texture plugin should be located is the home directory.

And it seems some problem when open texture plugin on Windows, if that dll file was compiled on MinGW.
First attempt to open plugin will be fails, but it can be used by reopen again.

I don’t know about sequence plugin well, but it’s probably not so different as texture plugin.
(I’m sorry, I’m not good at English.)

  • I don’t use user preferences at all, because I want it always default.
    If you set the path in user preference, you need to save that settings from the menu File->Save Default Settings.

tried updating the menu…i have tried putting the files everywhere i can think of and manually selecting them but whatever method or location always returns the same error ‘no plugin’ and then names the right file path and filename for the plugin???.. im so frustrated im considering deleting blender. Im running Vista 64bit o/s and have tried both 32bit and 64bit builds for blender - the program runs fine but i cant seem to load any plugins and also on the sripts page, i tried running python scripts that were listed and it told me they werent windows files and wouldnt run them either.

The only reason im still trying is that Blender seems to be an amazing piece of software that i would like to use to its full potential…there must be people who have had similar problems out there or a meta build using python 2.6?

just tried the scripts page and scripts seem to be working now…its only textures etc that i cant get blender to access

Maybe its a windows problem with some .dll files as mato says has happened before…can anyone confirm they’ve had similar problems?

parazaine,
hi, currently I am working on a Py 2.6 version.
You can however install python 2.5 & 2.6 on the same comp.
you can do a few things to fix your problems.
vista 32 bit & xp 32

So lets see if we can get things working.

First, lets set you up with scripts.

Regardless of what os you as using,
scripts live in .blender/scripts.
where .blender scripts lives can be confused by the installer.
so uninstall Blender.
Install Blender & choose Blender Install directory.
Do not choose App Data as this option belongs in the gtfo corner.
It will mess up the install. big time. f’n stupid idea.
So now Blender is installed all in the one place,
lets get all the scripts.
http://wiki.blender.org/index.php/Extensions:Py/Scripts/Catalog/Toolkits
scroll to the bottom of the page & download the all in one zip.
inside you will find folders & scripts ready to copy paste into .blender/scripts.
so do that, or manually copy paste what you like.
be careful of the bpymodules folder, make sure it overwrites/adds the extra files properly.
Now Open Blender.
Go to the Scripts window, start using scripts.

Plugins may present a problem with Vista 64.
I would not expect them to work.
They may work with Blender 32 bit run in compatibility mode.
Note also that Texture plugins work but sequencer plugins return errors.
(Nodes make up for that)

If you are trying to use my build, make sure you run it in 32 bit compatibility mode.
you will need python 2.5 installed for some scripts.
python 2.5 is not included in my build.
most scripts should work even without python 2.5.

If you are setting paths in User Preferences, make sure to use the file browser to browse where the scripts/plugins are.
Then press Ctrl/U to save user preferences so each time you open blender your paths are set.

give this a go & let me know if you have more problems.

Good Luck!

Thanks for your reply … I had already reinstalled Blender 2.48a and set it to install in the windows x86 programmes folder since my last post, I then installed Python 2.5 and reset the system paths ‘Path’ and ‘Pythonhome’ to python 2.5 and fired up Blender. It runs fine, finds python 2.5 ok and can access all the script files with the default settings but still wont load .dll files (textures or seq textures? not sure what .dll files are) I havent tried running in 32bit compatibility mode (is it the same as XP compatibility or in the same menu as that option? I will have a look after writing this - that may solve the problem… i will let you know if it does