Problems with rendering hair (grass) after baking

Greetings!

I’ve created a field of grass with a particle instance modifier attached to a plane. The particle instance modifier is of the hair type, and uses meshes from a predefined group of assorted grass blades/twigs/branches and so on. At this stage the grass renders just fine without any problems.

The problems arise when trying to bake the grass and render it after. Baking the grass is successful, and navigating through the timeline after baking makes it seem like everything went as it should, the grass is moving accordingly. However, when trying to render the grass after baking I come across two different problems depending on the type of children I use. If I’m using simple children for the grass, when hitting the render button all of the grass blades move to originate from the exact same spot, causing a weird clump of grass instead of a field of grass. If using interpolated children, all the grass blades grow to gigantic proportions (maybe five to six times as large as they are normally?). Would anyone have any idea of what the problem is? I’ve tried going through all the relevant options in the particle modifier options but haven’t managed to do anything. I also tried all the basics like applying scale/rotation but nothing seems to work.

I attached a few pictures to describe the situation further.

Thank you very much for your time!

Martti

Attachments




Check the modifier stack of your plane. Subsurf modifiers above particle systems can sometimes cause weird behavior if you styled the hair with another subsurf level. You can also check “use modifier stack” in the emission settings of the particle system, though this sometimes seems to result in no particles rendering. Bake it with the new settings and try again.

Interpolated children generally look better. You can adjust the size of them in the particle system render tab, I believe (Where you set your group), or you could just scale down your meshes.

I hope this was helpful!

Yeah, what mourlie said:

  1. Free the bake
  2. On the emitting mesh, change both subsurf levels to be the same, 1,1 or 2,2
    2b) Make sure your particle system is at the bottom of the stack (below susburf) use arrows to move.
  3. Check ‘use modifer stack’ checkbox at top of particle system
  4. Bake again