Problems with rendering particles

Hello everybody.
First of all I want to say, that I’m new with blender and I don’t know a lot of things about it.
Now, about the problem. So today I was messing around with blender. I made a cup (pretty ugly, but it worked for me) and thought of ading some smokes above it. I thought I will make smokes to say “SS” (For no reason). So I watched some tutorials, made text, transformed it into mesh, made domain (I think it’s called that), put my meshes there and etc. It worked fine. I were happy, but then I pressed F12 (I call it unhappy button from now). And instead of showing smokes, it shows black shadow from domain (only on things. It’s like transparent box that makes shadow) and no smokes. Like where the hell smokes dissapeared and why that box makes shadow? I tried to fix it so I may messed some settings little bit, but I had no changes…
Please help me. I really want to finish this one and to know what is wrong with it. That’s how I can improve, right?

P.S. I attached blend file so you can see problem. Because I don’t think you understood what I just said.

Attachments

cup_error.blend (2.33 MB)

The the CUP material under the Shadow panel enable ‘Receive Transparent’


Attachments

cup_error (2).blend (2.45 MB)

I checked it. That was pretty obvious, I feel dumb now not to see that option :o So there are no shaddows from domain, but I still can’t see smokes in rendered picture (even when I select method to display “rendered” I can’t see it. In other modes I can). In your attached file I can see smokes after renddering, but in my original one - no. I don’t get it :confused: