Problems with "set smooth".

Hey team, Me again.

Dunno if this issue has been raised before or not, but im having a lot of trouble with “set smooth”

sometimes, seemingly at random, when i set a mesh to Smooth, i get strange creases between faces, like shading that would suggest that the edges are not joined, when in fact they are.

I dunno if you know what im talking about, but for the life of me i cant fix it.

Ill post some photos when i get home (at work right now) and i would REALLY appreciate some help, as this has been bugging me for quite some time.

Recalculate normals? (ctrl+n)

That’s sort of normal for smoothing. It can take a bit of effort to look right.
One option is to add the Edge Split modifier. Then you can have it using auto smooth angle as well as with marked sharp edges.

For marked sharp edges go to Edge Tools More tab and turn on Draw Sharp.

perfect,
thanks!