Problems with shape key drivers

Hi All Can anyone help me out here (see attached). I’m using 2.57.1 (32-bit) on Windows. I have a mesh with a deform cage being modified by a shape key and a driver bone. I have dropped the default generator (I need a curve), and edited key frames as shown a simple bezier with two KFs. Bone rotation runs max 0 to min -55 deg (it’s constrained) But I can’t figure out the relationship between the curve Y-value and the final key value. In this case I’ve user y=100 at x=-55. But the output result is a tiny fraction!? Worse. The result seems to change unpredictably as I change the curve. I am unable to find a value that works. I’m clearly missing something. The first pic shows the the pose setup. In the second I have selected the deform mesh in order to check the shape key value (which is waaay too low). Does anyone have any clues? [Where have all my newlines gone!?]

Attachments



Are you expecting someone to tell you an exact driver equation without access to your blend file ?
I don’t believe Stephen Hawking is a forum member !

Surely the Y-value on the driver graph is fixed on some scale? The Obvious value would be 1.0 = full shape key. But that doesn’t seem to be it.

Here’s my take on driver set up,From what I’ve noticed with setting up drivers Y represents the value of the slider ie only set it to .1 if you want its whole range to be.10 and 1 if you want a slider that goes to 100% now to control the actual percentage of what you want changed this is what the -X and +X values do. That’s how I figure it out with trial and error on the x axis

Could be wrong and backwards but that’s my thoughts on it,

PS you might have more luck if you convert your rotation value to Radians

jonathan

Yep.

Thanks Jonathan.

Confirmed this morning.

X-input scale is in radians. So divide degrees by 57.2958
Y-output scale is unity i.e. 1.0 = 1.0

I’m sure I tried X-radians at one point, but I must have had my Y-scale wrong at the time.

Knowing you have at least ‘one’ of them right helps!

Ross.

[Who has finally found the ‘use basic editor’ check-box and recovered his newlines!]