Problems with smoothing out rounded surfaces

Hello all,

As you may or may not be aware (or care), I’ve been working on a sci-fi space carrier model. The hull is rounded on the sides, and has a lot of metal paneling.

As you can see from the shot, there is a lot of segmentation/faceting in certain parts of the hull curve (look towards the lower part of the hull in this shot). I’ve been trying to determine how to smooth this out without absolutely frying my computer.

Now, the obvious way to smooth most things in Blender is to use Sub-D, auto-smooth, and set-smooth in conjunction, basically the Blender equivalent of Max’s “set smooth” modifier.

The problem here is that I am not using any sub-d at all on the hull plates, and the poly count is already well over 1 million is a lot of shots, and goes as high as 1.6 million. I tried an experiment on a very small section of the plating, applying sub-d, and setting the border edges for all of the plates to 1.00 hardness, while the interior edges were set to 0. Even with only a small section of plate in the shot (none of the other plating was on a visible layer), even at low res, rendering took literally forever when Sub-D was set to 3. In fact, I didn’t let it finish. With sub-d at 2, rendering was dog-slow, but there was still a lot of segmentation visible.

I tried subdividing the plates, figuring that more edges closer together, would wind up looking smoother. No luck. It still seems segmented. I tried using “smooth” in edit mode, to no discernable effect.

Anyone else have any ideas, other than not trying to model such high-poly objects to begin with?



everything looks decently smooth to me.

except on those larger polys on the far right side that is. Try just selecting those large polys and setting those smooth.

Sorry, I don’t seethe problem you speak of. However, I see a few spots where you are getting black spots from set smooth. I’ve found that set smooth will cause this on planes that are perpendicular to other planes that are set smooth. For these flat areas set them to solid.

Maybe it would be more help if this image were default materials and lighting. Try posting a render from your 3d view window to highlight what your talking about better.