Problems with Transparent BSDF shader

Hi there all,
I’ve been having a problem with my project where the Transparent BSDF shader (or even PrincipledBSDF withno alpha) show up as black in places. I use a node group to control these things (its kinda messy sorry) and I’ll include some reference images along with the file itself. I tried cleaning up the mesh with recalculate normals outside and merge vertices by distance, but it didnt seem to make a difference. I also tried disconnecting the node group and replacing it with just a Principled BSDF shader with no alpha, but to no avail. I’d appreciate any tips any of you might have, and thanks for your time!

The file:

Note: the only difference with the renders I uploaded and the file I shared is that I removed the engine and it’s files from the shared file because it is payware and I don’t want to get in legal troulble :slight_smile:

For rendering in Cycles, you’re going to need many, many more transparency bounces. When it runs out of transparency bounces, it defaults to black. Look in properties/render/light paths.

For rendering in Eevee, which includes a material preview, you’re going to have to set a blend mode in the material settings (after changing renderer to Eevee.) I would strong recommend “alpha clip” as there’s pretty much zero chance that Blender is going to sort these meshes correctly.