Problems with using a picture/texture as the sky/background.

I’m making a level of sorts for my game (Which is being made using XNA, by the way, not the Blender Game Engine, if it makes a difference), and I’m wanting to put a texture as a sky, however, I’m having problems with doing so.

At first, nothing comes up, untill I play about with the “Paper Sky”, “Blend Sky” and “Real Sky” checkboxes, then I eventually get a negative/black & white version of the image.

I remember I once got it working ages ago by pure luck, but I haven’t been able to do it again.

So how do I do it?

Hi, start in World settings > Textures > add image > mark Influence Hori: and change the Mapping settings to the format of your image (AngMap, Global, etc.)

Cheers, mib.

also check the normals. are you using a cube, a plane, or what?
the normals of cubes and planes must be facing inside / down, respectively.

if you wan to check it, go in edit mode, press A to select all, and in the tools (left panel) find where it says “normals”, press “recalculate” and then “flip directions” (or inverse, or something like that, i don’t remember exaclty now).

I don’t see anything marked “mark influence”…

I don’t see “normals” anywhere there…

here it is.
remeber, you need to be on edit mode (object mode has different options). if the left panel is not showing up, press “T”.

Hi Cobra!, here:


It worked! Thank you so much!