Proper render settings for animations with sound

Hi.
As asked here, I’m having issues with rendering videos via the Blender internal video sequence editor. I’m not very used to these settings, so could anyone post his (or just working) render settings for videos with sound files. I’d be thankful :smiley:

lG, special_ops.

c’mon guys, no one? D:

lG, special_ops.

Just try some of the presets, such as MPEG / Xvid / MP3

They are all crashing my Blender, that’s my problem and why I’m asking for support :D.

lG, Special_Ops.

The only settings I got to render vid with sound is h264 with mp2 sound. I’m glad to see that its not just me with trouble

P.S. btw the default settings won’t work, turn quality up to maximum on everything, still compresses quite well

They are all crashing my Blender, that’s my problem and why I’m asking for support :D.

lG, Special_Ops.

I posted because you asked for settings that work and they do for me !
Your best solution would be to use another application to encode your final video/audio

When I try to render it with Mp2 it gives me an ‘Error initializing audio stream’ error. What audio format are you using for the sound files? Maybe that causes this error… Sorry that I misunderstood your post, Mr. Marklew; do you know a good freeware sound effects studio? Tryed out quite many, like Avidemux or VirtualDub, which did not have that time-line based sound adding that I like so much in Blender :smiley:

lG, Special_Ops.@Richard_Marklew

I’ve spent the $$ and purchased the AVS family of programs. Quite helpful and do a good job including simple audio editing and recording as well as video and even general maintenance. A suprisingly good set of programs.

I record in wav and converted and compressed to mp2 using avs. In the VSE I have tried xvid, jpeg and all the avi’s and mp3 and mp4 and ogg for sound and none of them worked well enough that I could make a vid, upload it to vimeo or youtube and have the audio and visual survive. I did this on windows xp pro as well a windows 7 computers, same corruption problems. As I said, the only consistently good quality I get is h264 with mp2 but I also preconvert the audio to mp2 before loading into the VSE.

First make sure you are updated to Blender 2.62, then
-Under the Render button, in Output category save as filename ending in .mpg then change output format to MPEG
-Under “Encoding” set Format to MPEG-2, then set Audio Codec to MP2
-Click the Scene button tab
-Under “Audio” category, click the drop-down box under Format and choose “Stereo”
(skip the rest of these steps if you are sure your compression settings are ok!)
and under Encoding choose DVD for first drop-down box (Preset) then change Audio Codec to MP2 (I got MP2, PCM, & Vorbis to work, also using H.264 format and H.264 preset with those audio formats)
(keep in mind, this Render button tab option changes the Format in the Scene button tab to 5.1)
-Change your resolution back to normal (DVD preset changes it).
-Click the Scene button tab
-Under “Audio” category, click the drop-down box under Format and choose “Stereo”

That is the only combination that worked for me with Blender 2.62 on either WinXP 32-bit or Win7 64-bit with no special codecs installed except default ones that came with Windows (except I installed x264vfw, which I don’t think is used by Blender when it does H.264).
(For quick tests, go to camera view (numpad 0) then click Render, Render OpenGL Animation)
Maybe it worked & your media player isn’t playing the audio. Try playing it using VLC.
Reply to let me know what works–especially if you find anything else that works.

Same trouble here, I had success at 720p with mpeg (ffmpeg) using flash codec with mp3 audio. The quality is not great however, but it does work without the failing audio stream issues elsewhere.

I went back to render using blender-2.57b-linux-glibc27-x86_64. Worked fine.

When I try to render it with Mp2 it gives me an ‘Error initializing audio stream’ error

i’ve been through some of these errors, and found the problem in the audio sample rate!
simply check if sample rate in the scene panel if it is 48k change it to have an 44.1k audio and try, some codecs don’t support 48k like flash.

OS: Ubuntu 10.04 64bit
Blender verson: 2.62 64it
this combination is my best try:
container:MPEG-4
video encode:MPEG-4 default (no options)
Audio encode:MP3

still can’t figure out how to encode audio in AC3, but some developer may notice this problem