Proper Setup with Multi-core GPU (GTX 690) on OSX

Hello smart people,

I’m wondering if you can help me figure out why my GTX 690 is only rendering one tile at a time.

I know they come internally SLI which Blender doesn’t like, however I’m on a Mac (10.9.2) and as I understand it that disables the SLI automatically.

My setup also includes a GTX 760. I have definitely selected “GTX 690 + 760” as the compute device in the settings. When I use that setup I render 2 tiles at once—one for the 760 and one more for the 690. When I select “GTX 690” only, then I render 1 tile at a time. Same of course when I select only the 760.

I expected that I should be able to render 3 tiles simultaneously (1 tile from the 760 and 2 more from the 690).

Is there some setting I’m missing?

Each GPU presents itself as one tile. So with two cards you will only see 2 tiles.

Hi Atom, thank you for the response!

Yes each GPU should present itself as one tile, but the GTX 690 is a multi-core unit: two separate GPUs wrapped in one package. Those, plus the GTX 760, should give me 3 tiles at a time should they not?