Proportional editing influence circle missing

Proportional editing is enabled, I’m in an edit mode (scale), and I’ve got no influence circle. Proportional editing is also not working.

I’ve tried zooming all the way out, and it’s not there, and I’ve tried zooming all the way in and I still can’t find it. I’ve also tried fervently scrolling in, and then fervently scrolling in the other direction to no avail.

Help?

This sounds like a video card issue. Who makes your video card? You may have luck if you change the Window Draw Method in the System section of User Preferences.

Nvidia. GTX260.

Edit: Downloading 2.57b cleared it up.