Proxies in the VSE: Assign Video

I had a huge video in the VSE and so I created a Proxy for it so I could scrub through it easily. However, the Proxy that it generated was of a different frame rate (original was 23.98 whereas this was 25) and, so, they were out of sync.

Anyway, here’s the main problem: I deleted that old file, and then I generated a new Proxy video (this time it’s an Image Sequence rather than a video and so there are no sync problems) but now I can’t get Blender to recognize it as the Proxy. It is apparently still looking for that old video to use as the Proxy.

Does anybody know how you can tell Blender which file (or Image Sequence) to use as the Proxy video?

My problem kind of morphed into something else.

Essentially, I couldn’t get any Proxies to appear when generated from a Meta-strip (which I was certain I had achieved in the past). I had deleted the old Proxies and so I really needed new ones. I could go to the Meta Strip > Strip > Rebuild Proxy and Timecode Indices and it would generate an Image Sequence…but I couldn’t get that to display at all.

So! I eventually “solved” this by

Tab on the Meta-Strip to expose its component parts >
Select the video strip which I want to have a Proxy for >
“N” to go into its Properties >
Check the “Proxy / Timecode” box >
Create or designate the folder you want the Proxy to be placed in >
Tab out of the Meta-strip’s component views and go back to the Meta-Strip >
“N” for the Properties panel >
Check the Meta-strip’s “Proxy / Timecode” box >
In the VSE window’s tabs, go to Strip >
Rebuild Proxy or Timecode Indices

…And it should then generate a new Proxy video (not an Image Sequence) in the folder that you had designated.

I doubt that this will be much assistance to anybody, but man have I had some issues with the VSE in general and the Proxies in particular!

I think it would be good to be able to simply create one’s own Proxy and just have greater control over this. (In fact, now that I look harder at it…it appears that this new Proxy is again out of sync by a few frames.)


You could always fall back on the swap folder trick. That is create the low res proxy in a folder called, for example “Online” while the original is in one called “offline”. When you are happy with the cut simply swap names of the folders (rename). Assuming they are in the same place Blender will assume the high res asset is the same clip.

Sadly this only works for media that is similar, where as you have converted to frame sequence.

Alternately why not stack both vision strips (hires and proxy) on top of each other in another scene. Mute the one you don’t want to see. Cut it up, then swap the strip mute (in the source scene) for hires render. As long as you are accessing another scenes VSE the images come across, not sure about sound, you may have to meta strip it with the original source audio.

EDIT: fixed?! what DOH!

The timecode should solve the slippage of sync but mileage varies depending on the codec you are using for source. You may be better with an intermediate codec for editing.

To be clear did you set the contents of the meta strip to ALSO have a proxy generated.

I note also that proxies really need to have a custom directory defined (and if possible TC set), otherwise they are a bit flaky.

3PointEdit,

I think what you were suggesting in the first response was to simply jerry-rig my own Proxy, right? (Create a simple video and import it and cut along with it?) I believe I tried that once and there were various obstacles preventing it from being very effective, though I can’t remember them.

I did indeed have to check BOTH the component video and also the Meta-strip as having a Proxy in the “N” panel.

And, of course, I definitely concur that Proxies are “Flaky”. For example…


Are they 4 frames ahead at the start? Also I notice that proxies are a different size (black bar down right side) and don’t scale accurately.

3PointEdit,

The four frames are evenly distributed: there are two missing at the start, and two missing at the end.

So, what I’m now doing is editing the Proxy video itself in the VSE, adding the four frames, and then going back to the main file. It is working, believe it or not!

The reason that the Proxy video does not appear properly scaled in my screencaps (and thanks for being so observant, by the way) was just because, at that instant, the Transform Strip wasn’t active. But, normally, they are properly scaled.

Oh no I meant that they are often the wrong width. What TC setting did you use?

I had “No Timecode in Use” selected.

But there are still a bunch of “.blen_tc” files (three each, to be exact) which exist in the Proxy’s folder. I don’t really understand any of that, really. (I guess that’s probably what allows it to sync up even though they are different frame rates?)

Hmm if you have time delete contents of proxy folder then rebuild but choose rec run for tc type.

Well…my editing of the faulty Proxy videos - adding two blank frames on both ends of the .AVI video - has worked out perfectly (apparently). The Proxy video and the hi-res videos are now perfectly synched up, to the exact frame.

Considering all the challenges I’ve had with this, I honestly just don’t want to risk screwing anything up.

But if you could still explain what the differences are between the various “Timecodes”, that would be great. In a previous thread I had, I don’t think anybody knew.

Timecode types generally refer to the way they are recorded, free run records like time of day (writing a time of day timestamp leaving gaps when not recording), where as record run would not produce gaps in time as it follows on from where it leaves off. BUT I don’t understand how they work in Blender.

My suggestion could be made in a duplicate of the .blend project using a different custom folder for proxy. Just interested to see if the fault is fixed by setting TC type, using either one.

3PointEdit,

Thanks for the description of the two types. I will probably do a test at some point.

Perhaps it relates to clips that have been recorded with pauses while recording, instead of stop/start. This then would interpret the type of time code depending on how it was set up in camera. But few domestic/amateur cameras allow this.

could one of you point me to a basic rundown of how the proxies are used in the VSE?

I’m unable to get any HD (.mov) files to playback in realtime in Blender unless I up the cache limit in my settings and do a sort of ram preview with Alt/Option + A


I’m hoping that by using the proxy settings in the “n” panel that I could rebuild the proxy and it would replace what’s on the timeline. Until I render out.


What am I doing wrong?

comeinandburn,

The basic process as I’ve come to use it is:

  1. Select the video strip in the VSE
  2. Go to the Properties, “N”, window >
  3. Check “Proxy” >
  4. Also check “Proxy Custom Directory” and create a new directory where you want it to store the proxy files at. (For me, it’s best to utilize this option because, in addition to the proxy video that Blender will generate, it will also generate three or four other odd files, and those can clutter up other directories, quickly.)
  5. In the main VSE window, go Strip > Rebuild Proxy and Timecode Indices

At this point, you’ll see Blender working away, generating the Proxies. (If they’re 50% size, it MIGHT take a few minutes.)

  1. Now, to display the Proxies in the VSE video preview window, go to that particular window and hit “N”.
  2. Go View Settings >
  3. Select the Proxy size that you had earlier chosen (50% or maybe you went smaller to 25%).

It should now be visible in the VSE preview window. And when you test Render out a frame, you’ll see it’s the full-size image, not the pixelated proxy video!


UPDATE: One final thing I forgot to note. Often times, after going through all those steps, the Proxy STILL won’t be visible. When that happens, I’ve found that just closing and then re-opening the program will finally make it visible.

thanks very much it worked great, I’m especially glad you put the update because it didn’t work in 2.62 but I just tried in 2.63 and things work well.

Ah, you’re welcome. I get so much help that it’s only fair that I give some, too!

I think that I submitted a Bug Report on the issue of it not appearing immediately. Maybe that’s why it’s fixed in 2.63, who knows?

Just had some issues with proxies not making their own folders so they just over write each other.