publisher 2.25 path NLA action scaling


(slikdigit) #1

how do you get an action using a path (say a walk cycle) to scale over more than 100 frames? not just the individual stride, but to slow down the whole action. changing the total action lenght doesn’t seem to work, and the demo file has a 100 frame path animation. Help!


(ilac) #2

Hmm - I not sure if I understood what you mean - but if I did then I’m stumped too! It stopping at 100 no matter what I do. I’ll try a again later. We’re probably missing something really obvious.

A possible solution might be to create another action of the same stride, give it a different name (eg “slow walk”) and scale the action in the action window - thereby slowing or speeding it up. Then in the NlA when you need a slower walk that follows a path use this instead of your regular walk. you could always blend from one to another! :slight_smile:

Hope this helps for now.

regards
Fabrizio


(slikdigit) #3

I’m not sure that would walk-I mean work, intrigueing as it sounds. Since I’m using stride length, the total time for one cycle (the action) is scaled to fit withing the range specified by the total length of the action (which I can’t seem to budge from 100 frames, no matter which setting I play with) the the length of the path, and the length of the stride.
for example: If the path was 50 long and the stride length 5, it would take 10 cycles (20 steps) to do the whole path, so 10 actions in 100 frames- each action would be scaled to 10 frames, regardless of whether you originally made it as a 60 frame action or a 100 frame action.
I have a sneaking suspicion this is a bug/oversight that NaN would have fixed in version 2.26.


(ilac) #4

Ha! Just remembered. Told you I was forgetting something obvious!

Select the path, go to the animation buttons menu (the one where you add particles, wave etc) On the left you’ll see the settings for your path. one of the settings is pathlen (path lenght). Adjust according to your hearts desires :slight_smile:


(slikdigit) #5

Hi Ilac. finally figured it out (and tested)
I was using a curve->path for the walk cycle path. even if I changed the path len like you said, it was effectively stuck at 100.
I did the same thing but this time used a nurbs curve, and was able to scale it as you said using path len.
Phew! with the current state of affairs of NaN, such problems become more ‘edgy’, cuz you don’t know if they will ever be fixed.


(theeth) #6

even if I changed the path len like you said, it was effectively stuck at 100.

it is not stuck at 100. When you create a Path (Curve -> Path), it comes with an already created path IPO (in the IPO window, under the tab that looks like a curvy arrow).

Whenever a curve path (NURBS, Bezier, Path, whatever) has a Path IPO curve, the PathLen button is useless, and the length of the animation is determined by the IPO curve.

The Path IPO curve works that way:

  • A value of 0.0 on the Y axis means that the object is at the start of the path.

  • A value of 1.0 on the Y axis means that the object is at the end of the path.

  • The X axis is the frame number at which the object will be at the given position.

  • You can effectivly slow down an object on a path, making it go backward, or even in loops.

Martin


(slikdigit) #7

thanks for the explanation, Martin.
I didn’t know that about the curve-path object. I just came back to post “I fixed it!” by using a nurbs-curve instead of a of a path curve as the path object. Now I know why that works.
Now I have a really bad walk cycle for blendo!


(Briggs) #8

>Since I’m using stride length

2.25 had a stride length tool? Fuck!

/me despairs over all the neat features in 2.25 that he and many other may never have now.