Pulling my hair out over this...

So, at some point in the past, I figured out how to blend materials, via Blender’s nodes. I got it down to where I could blend textures together, and then adjust them further by overlaying vertex colors.

Here’s a shot of one of my experiments…

As you can see… it came out fine. Sadly, the node tree is too small for me to make out what’s what. So, once upon a time… I “got it”. This was some time back.

Now, fast-forward to the present.

I’m trying to mix 4 materials together via a mix/color map, and try as I might - and even after looking it up online - I can not get it to work again. If someone could take a look at the screenshot below and let me know what I’m doing wrong… that would be most awesome and I’d really appreciate it. I’ve been trying to make this work for 2 days now, and it’s just not happening for me.

It should be self-explanatory, but basically, I have my 4 color materials on the top, and then on the bottom is the mix-map, which is supposed to be feeding the ‘factor’ for each of R, G and B.

All that’s happening when I paint is I’m getting red, green or blue on the object… not the textures. Ugh lol. Here’s the pic of my current node setup…

Thanks again for any help.

it looks like your mixing texture is black.

maybe you’re using two different UVs? Try using the ‘attribute’ node instead.

and you can take out the node bettween the UVcoords and the separeteRGB

It is in that picture, but even if I’m painting it, it doesn’t make a difference. The color I’m painting shows up on the mesh, not the material it’s associated with. Somewhere along the line, I’m missing something that’s translating “R”, “G” and “B” into each of their respective textures… which is what I thought the ‘factor’ input does on the Color Mix nodes.

You mean the one showing the black texture? That’s the color map, though. That’s what I’m painting in order to control what texture is displayed…

Or am I not understanding what you’re referring to?

No on all counts, those are not Cycles nodes and UV+texture suggest image texture.

The setup should work when the correct texture and UV map are used

Texture is added for one of the materials but doesn’t influence that material. Fake user is enabled so that Blender doesn’t get rid of it.


From this end, it looks like everything’s set up correctly. It just won’t work. I even re-created the whole setup from scratch again. Still nothing. I can not understand how I “got it” just fine last time I did this, and now I’m at a complete loss.

Two days now working at this, and I can’t get it to work. Very frustrating.

Although… Here’s something interesting I noticed… and it might be a clue as to what’s wrong…

Notice how the ‘output’ shows an actual texture… That’s the same texture I have set up in my first material slot, the one that blends with the ‘Red Channel’ material.

However, the cube is showing up as solid black, as though the black “mix map” texture I’m using to blend the materials is overriding that.

Might that have something to do with it?

So, I’m beginning to wonder if I’m using a bugged version of Blender or something. Either that, or there’s a step I’m missing that’s so ridiculously simple, that it’s staring me right in the face, and I’m just not seeing it.

I’ve now tried following a couple tutorials I found online using only the vertex colors, no colormap involved at all. I’m pulling it directly from the Geometry’s vertex color, with a color splitter dividing it into R, G and B, and with each color plugged into the ‘factor’ slot of the Mix node.

That’s not working, either. Instead of the material colors I’ve set for R, G and B… I’m just getting Red, Green and Blue. It’s completely ignoring my setup.

This is seriously bewildering to me, considering I had figured this all out just fine in the past.

@JA12… can you possibly post your sample file there somewhere so I can check it out and compare what you’ve done to what I’m doing. There’s something wrong somewhere, and I just can not figure it out on my own. Don’t know if you saved the file or not, but if you did, and if you could link it somewhere, that would be awesome. Thank you.

I’m going to figure this out no matter what.

Sure. I didn’t save it but I made another one.

Forgot to mention that enable glsl shading for viewport but it looked like you have some problem with the nodes too

mat_mask_ja12.blend (126 KB)

Awesome. Thank you, JA12.

I’ve tried it a few more times since my last post. I got the “color only” material version to work… once lol. Now I can’t get it to work again.

I think there’s a problem with how I’m defining my materials - as in, creating/defining them in the side-bar, versus creating/defining them in the node editor. Also, the way the material is supposed to be assigned to the object itself might be throwing me off.

Your sample file will likely answer my question, though.

Thanks again!

Okay, so I messed with your file and it works fine!

I wonder if the the GLSL thing was the issue all along? Because, really, from what I could see if your setup, at least a couple things I tried were pretty much identical. So, I guess it’s like I said… the problem was staring me in the face lol. Go figure.

I set up textures in each material slot, and it all seems to be fine now… So… There ya go. I’m going to keep your file as a reference, now, though lol. Just in case I have a ‘senior moment’ and get something wrong again :stuck_out_tongue:

Thank you again for the time and help! Very appreciated.