Purple highlighting and posing difficulties

Two questions, I think one easy and one hard. Please see attached image.

  1. What does it mean when the restrict viewport visibility and restrict rendering buttons are highlighted in purple? This is shown in the upper right of the attached png file.

  2. I made some characters in Makehuman. I bring them into Blender and they work for a while, and they slowly get “broken.” By broken, what happens is that when I start posing, the character “explodes” when I move some of the rigging. For example, the attached image is what happens when I try to lift the outer lips to make the character smile. My question is "what am I doing to break the characters and is there any way to fix them.


I’m not that familiar with the makehuman rig, so I’m guessing.

  1. The purple restrict visibility buttons mean they have a driver set on them. I’m guessing that the rig has options in the N-Panel to turn those items on and off. If it becomes an issue you can right click the buttons and choose remove driver, but you run the risk of breaking the rig. :slight_smile:

  2. My first thought is the rig has been scaled, and doesn’t scale well. If you could upload the .blend file it would be much easier to troubleshoot.

Thank you for the reply.

  1. Yes, it looks like it is a driver issue. If I right click on the purple part and select Delete Driver it does go away and allows me to exclude it from rendering. You’ve given me some homework - I’ll go read up on drivers and learn about them. Thank you.

  2. Wow. Scaling has been essential to the projects I’ve been doing. Not being able to scale things with rigs is going to present a challenge. Nevertheless, I’ll stop scaling and see if that makes the problem go away. It will take a while to know - sometimes the problem comes months after I import and scale the characters.

I tried to attach the blend file last night with the original post, but was unable to attach it for reasons I did not understand. I tried it again on this post and and still not able to. I just noticed that the there is a 15 MB limit on file size and the file is larger than that . I took out everything I could and it was still larger than 15MB. So I zipped it and the zip file is only 10MB which is under the limit. But I can’t get that file to upload either. I don’t know what I’m doing wrong. If you can tell me how to upload the blend file, I’ll upload it!