Putting Shadows on town

Good day :slight_smile:
I tried to put a shadow(spot) on the my town scene but it seems one spot is not enough so i put another one and now, it has a Blind spot where there is no shadow…when i scale the spot, the shadow doesn’t seem to be wide :frowning: What’s the trick for this one? this is my first time to put shadows and i really want that :smiley:

Head to graphicall.org, search for the harmony build, download it, add a sun, then enable shadows. You will have to mess around with the frustrum settings, but once you get a good setting it works like a treat. The harmony branch has quite a few changes and tweaks making the game engine that bit more powerful.