Python Errors With Exporters


(emtilt) #1

I just downloaded Python 2.0.1 so that I could use the PovRay and Renderman exporters. I installed it, But I can’t get them to work. I get errors everytime I try to use them. I know sometime you have to change some path setting, but I couldn’t figure out what. I know you’ve probably had to answer this kind of question a hundred times, but I would appreciate any kind of help. Thanks.

I am running Blender Publisher 2.25 on Windows 2000 pro.


(Enzoblue) #2

Go here and read my post. Just exchange Python20 for every Python22 you see unless you can get Python 2.2.2 which you should.

http://www.elysiun.com/forum/viewtopic.php?t=7723


(eeshlo) #3

While helpful, there are some errors in your post, for full compatibility you need Python2.0, Blender only uses python2.0, nothing else, even if you install a higher python version (which might work, but not for every script). The advice to copy python22.dll to the blender directory therefore also is unnecesarry as it isn’t used at all.

I’m working on adding my part to the pythonpath101 thread.


(Enzoblue) #4

K, I’ll change it. I have 3 python versions on my machine now I think… kinda confusing. Do I still need 1.5 for lightflow?


(eeshlo) #5

No, you don’t need python1.5 any more, I mention that quite a few times in the docs. So unless you need it for anything else, you can uninstall it