Python Scripts won't load - no error without -d

:-?Ok here’s the skinny:
Solaris 9
Blender 2.34-2.36 (tried all three)
Python 2.3.3
Scripts do run with ALT-P when opened in text editor
Blender dir: /opt/blender-2.36-solaris-2.8-sparc/
Python Bin: /opt/sfw/bin/python
print sys.path output:
[’/opt/sfw/lib/python2.3’, ‘/opt/sfw/lib/’, ‘/opt/sfw/lib/python2.3/’, ‘/opt/sfw/lib/python2.3/plat-sunos5’, ‘/opt/sfw/lib/python2.3/lib-tk’, ‘/opt/sfw/lib/python2.3/lib-dynload’, ‘/opt/blender-2.36-solaris-2.8-sparc’, ‘/opt/sfw/lib/python2.3/site-packages’, ‘/opt/sfw/lib/site-python’, ‘/opt/blender-2.36-solaris-2.8-sparc/’, ‘/home/qzm48g/.blender/scripts’]
Error reported with “blender -d -w”:
[i]Registering scripts in Blender menus …

Getting menu data for scripts from dir(s):

Warning: Registering scripts in menus – no info found.
Either your scripts dirs have no .py scripts or the scripts
don’t have a header with registration data.
Default scripts dir is: /home/qzm48g/.blender/scripts
User defined scripts dir is: /opt/blender-2.36-solaris-2.8-sparc/
ls of /home/qzm48g/.blender/scripts shows 64 .py scripts all confirmed to have the followinfg style headers:

Name: ‘Apply Deformation’
Blender: 234
Group: ‘Mesh’
Tooltip: ‘Create fixed copies of deformed meshes’

Of course the values for Name, Group and Tooltip vary , but all scripts are 232, 233 or 234.

But nothing will load.
I executed a truss against it and found that while it does execute a getdents64() system call, it does not ever attempt to open any of the .py files to even check for a header.
Any suggestions? :-?

Did you try to copy the scripts in :


Oh yes, definitely. I can provide truss output and an ls of ~/.blender.
Thr truss shows it does a getdents() system call , thus getting the list of files with .py (I even tried links to .PY .Py and .pY ) and it then goes to the next directory without so much as a stat or open on any of them.
I’m wondering if it’s a Solaris wierdness with the getdents64() that blender isn’t coded to handle… but I can’t get the source to build because I don’t have OpenAL libs or includes and can’t cvs to the net from here.