Quad Remesher auto-retopologizer

Did you try to assign the maximum amount of polygon density to the problem areas? I can imagine the source mesh is low-poly, but you could still try to paint the maximum poly density amount on the available polygons of the areas.



After spending an hour trying to successfully retopo this with Quad Remesher-- I’d say this is an edge case which cannot be solved. Perhaps @Metin_Seven you can forward Jerry’s file to the developer?

FWIW, as a Pro Purchaser, I did contact the developer through the form on the website over a week ago and have not heard anything. I was hoping for better support.

The Linux add-on currently does not work for me. I am currently using Wine 4.18-1 and blender 2.80-75.

Another user here experience the same no answer after more than a week!

1 Like

Could one of the owners of QuadRemesher run the Addon OptiLoops over a processed mesh? It would be interesting to see how well these two addons work together - in theory I imagine that to be quite nice. I’m just curious.

1 Like

I’ve used that before on quad remesher output to make it more efficient, and it’s not bad, though don’t expect a perfect cleanup solution due to how very regular the quad remesher output is, and how it disregards what the human brain does when modelling - aligning significant features on the same loops. This is not a bad thing, it’s just not how humans work. But I guess optiloops saves some manual loop selection.

Yeah, confirmed, it doesn’t work anymore.

Looks like there is a new version of the engine, and it no longer plays nice with Wine. It complains about not being able to find a .dll, but that .dll is right there in the same directory as the .exe. My guess is that it is now hard coded to look in a different location (for whatever reason), but I have no way of knowing for sure

Anyway, it was fun to get it working with Wine initially, but I’m not looking to become the full time maintainer of this. I don’t have the time or motivation.

I’ll leave it for someone else to fix, or for the developer to release an officially supported Linux version.

1 Like

Above i had the problem with (2.82.1 - Wine 4.18). Wine got updated to 4.19 and now it works again. YMMV

1 Like

This is the fact sometimes because I don’t like to paid for blender addons unless to get first’s users impression. Most of the time feedbacks help us to figure it out and take the right decision of it’s more as less worth to pay for it. I hope it’s not a case of a poorly and inefficient product support.
Good luck Chippwalter and the same for me since I also already bought it .

1 Like

Minor feature request. While you can turn on Symmetry and it works you don’t have the ability to choose which side of the base mesh the symmetry is drawing from. But it sometimes helps with Scans when one side of the scan is better than the other side.

I guess mirroring a mesh before running Quad Remesher is as much work as turning on a checkbox. :slightly_smiling_face:

Pro tip: hover your pointer over the Transform ➔ Scale value of the axis you want to mirror (e.g. X) and press the minus key. The scale value of that axis will become negative (= mirrored).

In case the side that becomes mirrored is still the wrong side after mirroring, press Control + A and apply the scale.

1 Like

In this one case it takes a few minutes for blender to chew through 4,691,188 Faces for a scan on my computer. I figured since quad remesher was doing the symmetry anyway it would be helpful to be able to pick which side it was doing.

1 Like

Interesting to watch comparisons, one day Blender integrated remesher will be same good as this plugin.

1 Like

Great tool to tame ugly CAD meshes. Using Quad Remesher with a high poly count in conjunction with OptiLoops produces really nice results.



@tinker @Van_Muscari

Changed my mind. I still don’t want to maintain this long term, however, it occurred to me what the issue was with my Linux adaptation of the script and it was an easy fix.

I can explain if anyone needs to know/has the interest. Basically versions of Wine seem to be inconsistent in how they handle the working directory, and I got lucky the first time. I now manually force the working directory, so this shouldn’t be an issue any longer.

It is working again on Linux via Wine. Version 2.1 available in my original post above.

1 Like

Your effort is truly appreciated. Thanks again!

1 Like

Would someone else please be able to try re-meshing this simple sculpt with x symmetry turned on and tell me if you also get the error “remeshing failed”?

I am trying to work out if this is a general error, to specific to me using it on Linux. The error happens only when I have symmetry turned on.

This is the first time I have had to properly call upon Quad Remesher since purchasing a licence and, I have to say, I am a little disappointed.

So far, I can’t get good results on what I thought would be quite a simple job. Lots of spiral loops without symmetry and, when I activate symmetry, it fails. I have got a much nicer result from Autopo in 3DCoat, so I might be sticking to that at this rate.

Can confirm it fails on Windows 10 with x symmetry checked and works without it.

Did try scaling it down to ~1m and slightly decimating the original mesh, both also failed the same way. There are some scattered intersecting faces in the hamster; I don’t know if that’s a problem or not.

Console shows: RETURNING ERROR… ProgressValueFloat=-1.0

Edit: adding a decimate modifier with a ratio of 0.5 did work.