Question about Building a Castle

Hi everybody

I am new here and I have a lot of question to ask so I hope you to help me , and forgive my English if there was a wrong in my posts

My first question is : in Building a Castle tutorial we started with changing the view to top by pressing numpad 7 then we add a circle then we returned to front view ( numpad 1 ( .

Here when I press button E nothing happened .

How can I extrude this circle ? help me please

You need to be in EDIT mode to extrude the circle. You do this by pressing the TAB key.

You will know you are in EDIT mode when you see a bunch of little dots instead of the pink/blue circle.


To Extrude you need to be in edit mode. select circle by right mouse click, it will turn pink and then push Tab, you will now see little vertices (dots) on your circle, Push “A” to select all (they will turn yellow) and now “E” to extrude.

When you add a circle and you want to EXTRUDE it, you must
stay in EDIT mode and all of the vertexes have to be selected
(yellow), if not in edit mode press TAB and if the vertexes
aren’t yellow but purple press ‘A’,…then in frontview with
all the vertexes still selected press ‘E’ en then click EXTRUDE
when Blender ask’s it,…then move your mouse up or down
in the way it has to be extrude…

hope this solve your problem?!?!


LOL did you guys all answer at tha same time. :wink:

Thanks everyone but when I was in the top view I see the yellow vertices and when I turned to front view then I saw nothing to extrude … and when I prsse E nothing happend

Did you see a “OK? Extrude” pop up?


You only see a few dots on one line in front view mode, because your circle is still flat. After pressing E, move your mouse upwards (while pressing CTRL so the mouse cursor is snapped to the grid) and you should see some lines appearing. If you see absolutely nothing, try to zoom in. If you still see nothing, I wouldn’t know what’s wrong.

Theeth : no I did not see this pop up
Soulsaver : I can not see any dots even with zoom in

it can be that the circle is outside your view window.
if you select the circle in top view, you can focus to it in side view by pressing the ‘.’ button on the numpad.

No it is not
It is in the middle of the window

what kind of a circle did you add?
as far as I know you can only extrude mesh>circle
instead of curve>nurbscirlce or curve>beziercircle.

I added just a circle
Add > mesh > circle

Problem solved .
I don not know why my keyboard never changed the view when I pressed the 7 and 1 … but the circle extruted when I changed the view from the view menu
Thanks to every one answered me

Hehe,…try to turn on NumLock :smiley:
Maybe you can show your creation when it’s finished?!?!?

Enjoy Blender!!


Exactly it is from the numlock
Thanks snowboarder

yep, that numlock sent me for a loop too, some time back. I thought I had broken my Blender for good, and it was very frustrating. I wish I had seen this thread sooner, i would have said something.

No problem … Thank you