Question on importing with textures.

Heya hi Blender community, this’ my first time on your forums. Got a question for you.

Along with fiddling around with basic graphics whatnot my other great joy is World of Warcraft. Then someone in my guild shows me the WoW Model Viewer. Fun utility. It opens the game files on your hard drive and lets you view all of the various models and animations from the game.

So here’s my cute little 60 hunter, Desiderius, recreated in the model viewer.

http://i89.photobucket.com/albums/k204/Dreilon/ModelViewer.jpg

Say hello, Des.

http://i89.photobucket.com/albums/k204/Dreilon/wave.jpg

Yeah, ok. Anyway.

Now I notice that the model viewer allows me to export models. And I have this epiphany: if I could import the game models directly into Blender, I could reanimate them myself for untold machinima potential. What fun that’d be!

And so I give it a try.

http://i89.photobucket.com/albums/k204/Dreilon/Export.jpg

Now here are my options.

http://i89.photobucket.com/albums/k204/Dreilon/ExportBox.jpg

I’ve messed with the various options, and none seem to quite work as I’d like. 3d Studio Max isn’t even supported yet. Closest I’ve come is the Wavefront .obj files. Lets give that a try.

http://i89.photobucket.com/albums/k204/Dreilon/ExportWave.jpg

Now we import it…

And I get this cute little dialogue box.

http://i89.photobucket.com/albums/k204/Dreilon/ImportBoxWave.jpg

In theory it’s importing materials. There is a .mtl file.

http://i89.photobucket.com/albums/k204/Dreilon/ImportWaveFiles.jpg

But when it imports:

http://i89.photobucket.com/albums/k204/Dreilon/Imported.jpg

No texture. AND it ninja’d my phat lewts somehow! Where are my shoulders? My beautiful sword? Gone! oh teh noez! …though I do like these new, happening shades.

So I’m new to Blender and feel this can be done. I just don’t know enough. You guys have any pointers? Thanks.

hi, are you sure there is no material/texture? what does it look like in textured view? (Alt+z)

You might also want to take a look at the UV editor and see whether the UV layout has been imported. If that’s the cause, it wont’ be hard to link it to the tga textures.

lastly, the accessories for the character could be on different layers, with your mouse in a 3d view port, try the ~ key.

and yes, the model is probably like that; it’s called a low-poly model so that it renders fast. Use Set Smooth to smooth him out, or subsurf.

Don’t really have much useful to add, just thought I would mention that the sunglasses-looking thingies are probably just a flat space to stick the mostly transparanet sideburns texture. I ran into this effect a lot in UT200x models. (or more, i ran into what happens when the thing forgets that the hair is supposed to have alpha channels . . . )

(Also, scared to see why MY little night-elf thingie would look like untextured now considering he’s got that “there’s a cabbage stuck to my head” ‘do’ . . .)

Ok, thanks for the pointers.

Yes, I understand it’s low-poly. Game and all. Blizzard was always a master of the minimal when it comes to all such, their texture work is just beautiful. Such a shame I can’t do justice to it.

Now it turns out I did need to hit alt-z. Hehe…whoops. Embarassing.

Although…

http://i89.photobucket.com/albums/k204/Dreilon/furbolg.jpg

Simply becomes…

http://i89.photobucket.com/albums/k204/Dreilon/furbtext.jpg

Yeah… I wouldn’t farm that for rep.

So, uh, I’m gonna need some of them there UV’s, aren’t I?

I’d think the .obj file-type can include them, some way to import those properly?

Thanks again for the help.

Hi Desiderius,

I was wondering if you’ve had any luck importing the UV Maps. I’m having the same problem, the texture is there, but the maps are applied randomly to the areas of the model.
Any update?

Or has anyone else had success with importing WoW models?

The uv coords are definitely in there. To see them, go into face select mode, press A to select all faces, then look in the UV/Image editor window.