Question on why my meshes are showing like this.

Hello, I’m having a problem with the way blender is showing the meshes in the 3d view. I have a couple screen layouts set up. The default one is fine. The meshes show fine in that, but when I switch to another one, the meshes edges have this outline around them and it kind of looks like what you would see with a subsurface modifier on, but there are no modifiers on them. They show up like this when I create them. I think it’s related to the option at the bottom labeled: “Limit selection to visible” because each time I create a new 3d view that is off by default and I turn it on.

So you can see in the picture the vertical edge on the right has the black outline with the actual mesh edge curved in a little bit.

Appreciate if someone who knew what was happening or what setting is causing this could help me out. Thanks!

Ensure you haven’t changed the default viewport start/end clip distances