queston on yafray and specularity

What is with the intensity of the specularity in the closet? I’ve tried turning the specularity off on the light source (Lamp) in the closet, but nothing changes. I’ve also turned the spec all the way down on the wall texture and it’s still the same intensity. I even changed the spec color to match the diffuse color. What am I doing wrong?


Be aware that specular shows even when an obstacle is between the light and the camera. But if you turn off specular on light it must not show. So it has to be another light that produces the specularity there…