Quick noob question.

Hey, thanks for looking.

Can someone help me with this problem?

When I go into edit mode on my object it won’t let me select any vertex points in vertex mode, But if I go to edge mode or face select It will let me.

For some strange reason I can’t select any vertex points(with right click or box select) on my mesh in vertex select mode.

Note: The other objects in my scene don’t have that problem, only this one.

I was able to select them before, but maybe I pressed some button by an accident that I don’t know about, Help would be much appreciated.

Thats odd…

Have you tried remove double on the verticies?

Just tried to remove doubles, it did not solve the problem but it did take care of some extra vertex things.

thanks for trying to help and with a speedy answer

This may sound a bit simple, but in user preferences—>Themes—>3D view Are the vertex and vertex selected colors the same?

Ooops, missed the part about other objects not having the problem. That is strange. If you append the object to a new scene, is the problem still there?

Yes the problem still exists after moving the object to another file, I found that I can click them when I have the object transparent, but when it’s not maybe the object itself gets in the way of the vertex points.