Quick selection problem

Okay so when i go to front view orthographic and hold down b and select the top half of this sphere. It selects, but it does a camera based selection. I know there was a way to easily turn this off in maya but how would i do it in blender, so it selects the entire top half of the sphere?


Disable ‘limit selection to visible’

http://wiki.blender.org/uploads/b/be/25-Manual-Modeling-Meshes-Selection-mode-buttons.png

Or do the selection in wireframe mode.

Thank you. :slight_smile: