Quick Smoke (fire) does not show in Viewport in linux

I have the newest blender installed (2.82) in linux. My graphics card is the Nvidia Quadro 2100M. In windows the smoke is visible (however, I think I have version 2.80 installed there) but in linux I see nothing.

When you compare between OSs, you try to use exactly the same version of Blender in both:
And also the same .blend file.

Does the problem occur with any scene? You share here a simple .blend file where you can reproduce the problem.

Wait, at 2.82 we already have Mantaflow. You go to domain settings and Cache item you select Type > Replay. Otherwise you need to bake the simulation first.