Quicktime RGBA Alpha Not Working

Hi All

I have rendered out a quicktime movie with an alpha channel using the animation codec and specifying RGBA as the output.

In image #1 you can see that Blender does detect the alpha channel.

In image #2, you can see the render engine does not. This output came from the Internal Blender Renderer.

Can this be fixed?

Attachments



Have you got ‘UseAlpha’ on in the texture settings, and is the texture mapped to alpha?

Broken,
Yes, I have UseAlpha turned on for the texture. As you can see in the image, the alpha is detected by the Blender Interface.

I have tried turning on the mapped to alpha. It has three states, off, white and yellow. I have tried a render with each state.
With the map to alpha turned off, I get a grey background which is the default color of the plane.
If I turn it on (white or yellow), I get a black background which was the color of my comp background color in After Effects where I generated the Quicktime movie. This seems to be the flaw, the blender internal renderer has an error.

I have posted about this problem in the past, but no one seems to be able to re-create my problems. They generally toss my posts off as user error. However, I do believe there is an alpha problem in blender. I t also has problems with certain PNG files I have tried using as maps.
I have seen this problem go “unfixed” for 3 version now.

I like to do cutouts in my 3D renderings and I need the transparency of an alpha channel to accomplish my goals.

Set the alpha slider of the material down to 0? With Alpha (white) set in the map to section as well. Just trying to get a full understanding. Not chalking it up to user error but it has to be 100% denied as such to determine if there is a bug here.

Thanks for the replies.

I did find a solution using nodes.
I am posting a screen grab of my final layout.

I took the material block completely out of the solution and everything worked. It is one of the most basic material setups. I think the material block was a bit much for my needs.:slight_smile:

I realize now I could have probably used only a single texture input node, however as a video compositor I often have my alpha channel in it’s own seperate file. So having two nodes allows me to resuse the setup for future projects.

Attachments


Could you post a Blend for others to look at? As it is, it’s hard to understand what your asking.

It “looks” like you have a texture with alpha, (the Quicktime video?) that is mapped to a plane that is then being rendered against the world background, and the problem you are having is with the alpha where it effects the plane.

But, what you say seems to imply that the problem is with the final render to Quicktime with render to RGBA not producing an alpha channel in the Quicktime movie itself, and you have the movie loaded in Blender to show that the alpha channel is not there.

As I said a Blend would really help sort this out.

Pappy

Yeah,

I wish I could post a blend file.

What’s up with that anyway? I can upload a JPEG or PNG, surely this extenstion list can be extended.

Why doesn’t the sysadmin simply turn on extensions for ZIP or blend.

I have a solution, so I am moving on.